How can I remove Ralink2RT2500USB WLAN?

  Colline 16:50 03 Jan 2008

I have had problems with my Ralink2RT2500USB WLAN for 3 years and want to remove it, but do not know what to look for. Is it a physical piece of gear on the motherboard that I can disconnect from a USB connection or is it an integated piece of kit that cannot be physically removed?
Background - the problem is on a desktop computer running Windows XP SP2.
The problem is basically caused by (I think) IRQ conflicts. The desktop is 3 years old and came with allegedly USB2. When the WLAN is loaded on bootup I regularly get the message "this device can perform faster....connect to USB2...."
I have a printer, wireless keyboard & mouse, and card readers connected to the USB controller.
The Ralink loads and disconnects frequently but erratically (Railink Icon goes from green to yellow to black (disconnected/not exist). Sometimes it will stabilise and I have good internet connection; other times it remains black. Often when this happens I cannot shut Windows down (except by turning the power switch off).
So, my preferred solution is to remove the Ralink - but what is there to remove? - and install a WLAN card in a spare pci slot.
The reason I want to remove the Ralink physically is when I remove the programme (driver presumably) when I boot up Windows finds new hardware and wants to reinstall it.
Other info:
I have 3 other computers on my home network. All work well. I have a good wifi signal from a Netgear rangemax router throughout the house.

  recap 18:39 03 Jan 2008

click here for the latest driver, it may help with your problem?

  Colline 10:34 04 Jan 2008

Thanks for the latest drivers but it hasn't fixed the problem.
I used them in both Ralink and Zero configuration modes and optimising WiFi and optimising performance and I still get the WLAN hardware disconnecting (my wireless network index number is now up to 24!!)
Basically I think the hardware must be defective, but I do not know how to permanently disable it. Everytime I boot up PnP finds it and tries to reinstall it.
Other possible relevant info: I have a microstar motherboard (MS-7091) with an Intel 915G/GV (Grantsdale)chipset.
The mainboard has 5 USB Controllers but I can't identify which one has the WLAN hardware on. SiSofware indicates a X10 USB Wireless Transceiver (ACPI compliant) on one of the USB hubs.
My BIOS is out of date but I've not got the courage to flash it.
Does anybody have idea how to permanently disable the transceiver if that's what I need to do.

  recap 16:13 04 Jan 2008

Try disabling it from Network Connections. Right click the device and select Disable.

  Colline 17:52 04 Jan 2008

Thanks. I'll give it a try but it didn't work in the past (when I still had Ralink loaded). Windows would reenable it on boot up. Now I have removed Ralink as a programme AND disabled the device from Device manager (it no longer shows up in my network coonections list because I've removed the programme). What I fear will happen is when I next boot up Windows will enable it; I'll see. If it doesn't then it will have fixed the issue - :-)

  Colline 18:18 05 Jan 2008

As follow up the problem maybe something else....
I have successfully "removed" the Ralink WLAN receiver by both removing the software programme and disabling the transceiver via the device manager. Thanks for that.
But, the computer still hangs up sometimes (won't complete the shutdown routine and has to be shutdown by turning off the power) and when booting up it reports "This device could perform faster if connected to a high speed hub..."The offending hardware is it seems the generic volume on my hp psc2210 all in one printer. the generic volume is a photo card reader. I'm going to disable that and see what happens... Getting there.

  recap 19:59 05 Jan 2008

Have a look in Event Viewer for any errors on this issue. Post the Event ID and Source.

Event Viewer can be found in Control Panel/Administrative Tools. Open the System log when you have navigated to the Viewer.

  Colline 10:52 08 Jan 2008

Thanks for the advice. I've followed up with looking at Event Viewer and Programme Viewer. I found a lot of error logs, especially in the event viewer. They may be why the computer keeps hanging on shutdown, although the timing does not correspond to when I tried to shutdown the computer.
The main error logs were DCOM ones and related to several applications that did not have corresponding values in the registry. I've addressed these and will see what happens.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?