Hot Swapping SATA Drive Locks PC

  PaulB2005 12:35 30 May 2008

I have a home built PC. AMD 64 3200+, Asus A8N-SLi Deluxe Mobo, 1 Gb RAM, XP Pro.

Part of the motherboard kit includes an external SATA connector kit. In the past I've Hot Swapped SATA drives to perform data recovery with the PC on and then used the Safely Remove Hardware Wizard to disconnect them.

I found an old SATA Removable Caddy and a SATA 80 Gb Drive (Seagate ST380817AS) left over from a project i abandoned 3 years ago and decided to make the drive into an Offline backup. i.e. slide drive in, backup, remove and store in a safe place. The problem is the drive will not Hot Swap without locking the PC up!

Even if i take the Caddy out of the equation and i Hot Swap the drive directly cabled to the Motherboard it just locks up. If i start the PC with the Caddy in, all works well, but even using the Safely Remove Hardware Wizard causes the PC to lock up. I can use the drive if i power down, insert the drive, power up, backup, power down, remove the drive, power up, but this defeats the point of it being "Hot Swappable".

All drivers are up to date, latest BIOS. Tried various SATA Cables and power connectors, Drive passes all tests (CHKDSK, Seatools etc)

Any ideas? I'm guessing the drive is at fault as other drives have worked fine. I don't have another drive to hand to try it with at the minute....

  Ditch999 13:01 30 May 2008

Did you delete the partition and format the drive before inserting it with the caddy? It might be a drive letter conflict with another drive that is/was attached to your PC.

  PaulB2005 17:47 30 May 2008

The drive had been formatted a while back. I've since formatted the drive several times.

  Ditch999 17:56 30 May 2008

Start the PC with the drive attached on eSATA. Then go to disk management Start>Run>compmgmt.msc and select the disk. Right click on it and select Change Drive Letter and Paths. Then change it from whatever it is, to something further down the alphabet like M: Close, shut down, unplug drive, start PC, plug in drive and see if it works.

  PaulB2005 16:25 31 May 2008


Thank you - it looks like you were right first time. I noticed under Disk Managment then drive was showing as Active - the drive was bootable before. Deleted the partition once more and did a full (i.e. non-quick) format and presto all works. Can eject from PC using Safely Remove Hardware and insert the drive when i want.


  woodchip 16:34 31 May 2008

Not the Drive, It as to be either the BIOS or Windows. It freezes because its looking for the drive, After it freezes have you tried putting the drive back in to see if it unlocks it?

  woodchip 16:35 31 May 2008

sorry see you found the problem

  Ditch999 16:35 31 May 2008

Glad to hear it!
Its our wedding anniversary on Tuesday and I might have just persuaded my wife to buy me an eSATA drive for my PC (Asus A8N-SLI Premium) to do external images. Glad to know it works with the supplied bracket!! :-))

  PaulB2005 17:04 31 May 2008

woodchip - "It freezes because its looking for the drive, After it freezes have you tried putting the drive back in to see if it unlocks it?" Well it was freezing when it was put in and once that happened it stayed like that until you killed the power. Nothing bought it back. Thanks anyway.

Ditch999 - Hmmm in the past i was just pulling drives out of PCs and plugging them into the eSATA bracket supplied with the mobo using normal SATA cables and power leads. These weren't dedicated eSATA drives. Not sure we're talking about the same thing. Did you get a PCI Slot bracket that can connected to 1 or 2 SATA Ports and a Power Supply cable to allow the use of SATA drive outside the PC case? All the examples i've seen of it in use have had normal bare-bones drives plugged in - the ports have the L shaped connectors....

  PaulB2005 17:11 31 May 2008

Ditch999 - actually it looks like it's called a SATA Extension Module. Covered in the last 2 pages of my mobo manual. Manual is here - click here 8.2 Mb PDF Page 181.

Is this the same as an eSATA drive?

  Ditch999 17:12 31 May 2008

I havent actually looked at the bracket lately, just remembered it was in the box and if I remember right it had the L shaped connector but no power supply. I intended getting an external drive with its own power supply anyway.
Off to the attic now to check! If you dont hear from me again then you will know the wife has pushed me down the attic stairs to save a bit of money!!!!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?