help on a read only sd card

  trish2753 11:24 10 Apr 2011

I have a tom tom sat nav and the 1gb sd isnt big enough for the download and to add more poi's. I have a spare 4gb sd card which was used in my smart phone I have tried to delete the contents and it says this is write protected how can I format the sd card, I have looked at help and it said to uncheck the read only check box but there is no check box in properties to uncheck. can anyone help on this please or do I have to buy a new sd card?

  Thalmus 11:30 10 Apr 2011

Have you tried sliding the little switch on the side to its other position?

  trish1997 11:45 10 Apr 2011

what switch on the side? I have a tom tom one and the sd card doesnt have any switches on the sides???

  Thalmus 11:48 10 Apr 2011

The switch on the side of you're SD card (next to where it says "lock"). THis is a write-protect switch, if is enabled you won't be able to delete anything from the card

  WHTDSOB 11:49 10 Apr 2011

Has the 4Gb card got a switch? link text

1: this

  trish1997 11:53 10 Apr 2011

I am using a micro Sd card in an adaptor for the tom tom and there is no switch on the micro card nor the adaptor.

  WHTDSOB 11:56 10 Apr 2011

Try again. You have to move out of the post to repost!!

trying again

  Thalmus 12:03 10 Apr 2011

OK, i'm going need some info then.

What tomtom are you using? Am I right in saying the you got the card in the adaptor plugged into the pc and you're using the tomtom software to update it? Is it the tomtom software giving you the error? Have you formatted the card since removing it from your phone?

  trish1997 12:08 10 Apr 2011

I cannot format the card for use in my tom tom one, I tried to format it before use in the tom tom but could not so hoped that the Sd would be big enough to take everything ie maps and poi's but the tom tom is giving me the error and when I took it out of the tom tom to format it I cannot. I have it plugged in the pc at the moment trying various things you guys tell me.

  Thalmus 12:12 10 Apr 2011

Have you tried formatting in windows? To do so, right click the drive in computer and choose format. Note that some tomtoms only recognise FAT32 file system, so make sure this is selected in the file format drop-down

  trish1997 12:19 10 Apr 2011

Yes I have tried formatting the drive in windows explorer but it says the drive is write protected.

I have tried since unchecking the box on read only.

I have found the switch on the side of the adaptor and slid that to the other position and I can now delete the files but not the folders, they are still protected. There is no switch on the micro Sd card though?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Les meilleures enceintes Bluetooth à moins de 150 euros