help! php gallery problems right over my head

  mco 23:36 18 Nov 2005

I've had a php gallery with my site for over a year with no problems. click here It's singapore opensource; I don't understand the coding; all I do is upload images to subgalleries and it automatically makes thumbnails which enlarge if you click on them. Just recently when I've tried uploading, the thumbnails work fine but when you click you just get a red cross. Try this: click here I tried the singapore forum but it seems only one person a day accesses it - and that one person said all they got was 'permission denied' (I'm getting a red X) The said check the chmod is 777. Means nothing to me but I looked at the gallery folder in an ftp program; it said 765 so I tried to change it to 777 and it said 'server does not support modifying attributes ' - er? The main site is hosted by lycos and although I can access the gallery there in thei webftp, I can't find the 'chmod' permissions thing and can't understand how the rest of it works. Please help someone!!!

  mco 23:38 18 Nov 2005

Sometimes if you delete the photo and upload it again, it works. But I have repeatedly tried that and it still doesn't work. (and sorry for typos in previous post)

  harristweed 08:23 19 Nov 2005

If you don't understand chmod, how did you get it all to work in the first place?

  mco 10:19 19 Nov 2005

the first site I made was and is hosted by Lycos and is one of those easy-peasy wysiwyg webbuilder programs. You can add to it stuff like a gallery from a selection they offer and they do all the complicated set up for you, just by you clicking a button. Fine if it works. But they offer no support for other companies' software. And now I need to figure it out myself!

  harristweed 12:02 19 Nov 2005

OK. I think it’s almost certainly a CHMOD issue. You need to CHMOD the folder that the images are in to 777. (this means that the folder can be written to by the software). The way to do this is with an FTP program. Cuteftp for instance. You should be able to download a trial version that you can use.

click here

From memory,I think it's-Select the folder to CHMOD and right click. Select properties. From here set to 777. It all should then work correctly.

  harristweed 12:06 19 Nov 2005

Just re-read your post. If you can't change the permissions to 777, I don't understand how you got it to work with some folders and not others?

  mco 12:58 19 Nov 2005

Well I don't know either! The problem's only occurred in the last few weeks so whether there's a gremlin that's decided of its own accord to change the chmod, I don't know. But how I
can change it back if it won't let me I don't know. I'll go back to my ftp program and look again.

  harristweed 13:06 19 Nov 2005

If that's not it, what else could it be?

The photos seem to be in folders that have names generated by the gallery software.

The folder that gives the problem is the only one with a colon (:) in the name.

Try making a new section, use the same name, Climate Change: How do we stop it?

but leave out the colon and see if that works.......

Climate Change How do we stop it?

  harristweed 13:08 19 Nov 2005

also leave off the ?

Climate Change How do we stop it

  mco 13:12 19 Nov 2005

will get back!

  mco 13:26 19 Nov 2005

Well, did as you advised - and it's working fine to me!! See if you can see the enlarged images. If you can, everyone can. So are you suggesting the punctuation has a bearing on whether it works or not? I'm going to tick this thread with fingers crossed that you've sorted me out!
click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?