Help needed with new hard drive enclosure.

  lagalloise 18:46 15 Jan 2009

I got a new computer a while back and needed to transfer the stuff off my old ide hard drive onto my new (sata) one.

I got an enclosure, which seems to work fine - I plugged it in, switched it on and the computer seemed to recognise it - it started installing the driver, then said device was ready to use.

However, now I can't find it anywhere on my computer!

I've tried taking out the jumper switch to swap it around to see if that makes a difference as it was the master drive on my old computer, but it's pretty well lodged on and won't come off. The picture on the hard drive seems to say that no jumper = slave drive so I have a feeling that might work, but I don't want to try to much as I'm scared of damaging the pins.

Can anyone advise me on what to do next?

  MAJ 18:59 15 Jan 2009

Leave it as Master.

  canarieslover 19:00 15 Jan 2009

If it is in an external caddy then it should be set as master so you are O.K. Check the USB ports in Device Manager to see if there are any exclamation marks beside them. You might have to uninstall USB and let Windows re-install it.

  T0SH 19:05 15 Jan 2009

Try right click Manage on My Computer, then Disk Management, you should see your new drive listed as Disk (x) but unlike any others it will have no detail to the right

Right click on the word Disk (x) and choose to Initialise

once this is done it will now show to the right as unallocated space, where you can again right click and choose Format, when this is complete it will have been given a drive letter and will show in a Windows Explorer window

Cheers HC

  MAJ 19:11 15 Jan 2009

Last thing you want to do, if you're trying to get files off it, is format the drive, that will wipe it clean.

  lagalloise 22:58 15 Jan 2009

Hi, thanks to all for responses. Yep, definitely don't want to format it yet until I have all my files from it.

I just plugged it in again having been out for a while and windows seemed to see it as a new device and intalled the driver again. But still no joy. I did what you suggested TOSH and in disk manager it shows as 'disk 5, unknown, not initialized' but when I clicked initialize it said 'device not ready'.

Forgot to say, I have windows vista (if that makes any difference).

  Spark6 23:17 15 Jan 2009

Do you have a memory stick to check your USB? Try one, and if your machine recognises it and you are able to read the data off it, then the problem is with your HDD/caddy. In 'My Computer' what is the stick described as?

  lagalloise 23:31 15 Jan 2009

I don't have a memory stick but I do have my ipod plugged in at the same time and that's fine. It comes up in my computer as K.

It might just be the caddy.. I'm getting so fed up with them! It's the 3rd one I've bought and none have so far worked.

  DieSse 01:09 16 Jan 2009

Check that the power adapter is working on the caddy - they usually get warm if they are.

  Spark6 10:13 16 Jan 2009

To have 3 failed caddies, assuming they had a common fault, is unusual to say the least. Are you able to have them checked out on another machine?

You have proved, successfully, the USB connection on your new machine, get the caddies checked out.

  Pamy 10:21 16 Jan 2009

I have an old IDE drive that will not show up on my USB2, but works fine when plugged into USB1.1
Not much help to you ,just a statement, some very old drives do not work on USB 2

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Les meilleurs logiciels de montage vidéo gratuits (en 2017)