Help needed with file sharing set up

  jeano 02:42 24 Jul 2007
Locked

I've been tryin to set up file sharing on new wireless network. (I'd actually like printer sharing too but one thing at a time eh! Can't seem to get it to work.

Wireless network set up

Netgear DG834T Wireless ASDL router connected to desktop via Ethernet cable. Acer laptop with Atheros AR5005G Wireless network adapter. Desktop running Windows XP Pro and Norton Internet Security 2007. Laptop running Windows XP Media and Norton Internet Security 2004. Windows firewall disabled on both m/cs. WPA encryption enabled on router. Wireless access is also configured via MAC address. Firmware updated to latest version. Internet connection(s) working OK. Trying to set up file sharing between two m/cs. What I have done so far:

Set up unique machine names and common workgroup name. Used Network setup wizard to setup file and printer sharing. Created Shared folder on both mcs. Enabled guest login on both machines. Added IP accounts (range) in NIS Firewall settings. Turned off simple file sharing.

Machines show slightly different errors:
On laptop – My Network Places – View workgroup computers - displays Workgroup name in URL and shows desktop machine description and machine name. If I double click on machine name I get message with Workgroup name displayed in banner and “\\machinename is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. The network path was not found.”

My Network Places now on Start menu.

On desktop – My Network Places – (via control panel) only shows Router. View workgoup computers displays error msg “My Network Places” displayed in banner and
“Workgroup” is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. The list of servers for this group is not currently available.”

My Network Places not on Start menu

I don’t know what else to try – any ideas folks.

  ambra4 04:09 24 Jul 2007

Try this site

4 steps to set up your home wireless network

click here

  jeano 19:05 24 Jul 2007

Thanks ambra4 - not a problem setting up the wireless network - this is in place and have been using for internet connection for a couple of weeks now. It is just the ability share files (and in the case of the desktop) to actually see the laptop. Then there is the issue of the permissions error messages.

Anyone else think of anything I've missed.

  Toffly 00:58 25 Jul 2007

Have you created the user account for both accounts on both machines? i.e. if user1 on computer1 wants to access files on computer2, then they need an identical user account (user1, same password and permissions) with the correct permissions on computer2 and the folder on computer2, and vice versa.

And remember you must specifically allow rights to the folder, otherwise it is essentially denied.


It may be different on XP, but I remember from setting 2k work groups up in the past that user accounts must be made on all computers, as there is no central store for user account information.

  jeano 19:08 25 Jul 2007

Thanks I will try this when I can get my hands on the laptop and see if by logging in as guest (which I have enabled on both machines) will help.

So basically, no one can see anything else I should have done or done differently.

  Toffly 23:51 25 Jul 2007

You could try connecting them directly, make sure that the router isn't being a pain. Remember that you need a cross over ethernet cable, not straight through.

  jeano 16:02 29 Jul 2007

Thanks Toffly I'm sure user accounts OK in XP. Guest login has been enabled and all access rights have been given to the test folders I set up on each machine for share purposes.

Re the crossover cable - I would have to buy one as the one I received with laptop is probably a straight through. I have tried pinging the ip address of the laptop from desktop and this seems to work but it still doesn't see the network. If a try Run then \\computername I get "the network path was not found" - on both machines. Trouble is with these wizards all you seem to be able to do is repeat yourself and they don't display previous values. Any one know how to view the previously entered settings on these network wizards or an alternative way of setting things up without using a wizard?

  jeano 23:14 30 Jul 2007

In the absence of any better ideas tried using the wizard for setting up wireless network again (on desktop) but this time used the default options and saved the results to a removable device (memory stick). Inserted the memory stick into the laptop and it behaved as socumented and saved the settings to the laptop. However, access to the internet was lost and I can only assume that the new settings were not compatible with the WPA encryption key that I had entered into the router, desktop and laptop. I had to re-run the wizard on laptop and enter the previous encyrption key to get internet sharing back. Does this give anyone any clues as to why I cannot browse the network even though the laptop can see the workgroup. (just to confirm - the desktop cannot find any matching workgroup).

Help still required. Any ideas welcome.

  ambra4 12:38 31 Jul 2007

Try this

click here

  ambra4 12:42 31 Jul 2007

For printer sharing over the network check here


click here

  Toffly 20:42 31 Jul 2007

Try connecting both computer together with the lead you have, and assign them the following network details;

IP address: 10.0.0.1 and 10.0.0.2
Subnetmask: 255.0.0.0

And then try and get them to ping each other. If they ping, then the network adapters are auto detecting, so you don't need a crossover cable.

Try right clicking my computer and go to properties, and then onto computer name tab. Just double check that workgroup names are the same, and the computer names are different.

If they're correct, trying creating 2 user accounts on both computers, user1 and user2, with the password "password", and then make sure that both have full control to the shared folder. I just wanna double check that the fact that you're using guest accounts isn't a problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?