Help! My USB ports stopped working

  Black_Rain 10:15 18 Dec 2008
Locked

awhile ago, all my usb ports stopped working aside from one. What can I do to fix this?

The only one that is working is the one that the mouse is plugged into.

The others dont register devices, but i dont think the hardware is bad though because I plug my ipod into it, and it lights up, but doesn't start charging or connect or anything.

  tullie 14:48 18 Dec 2008

Does your mouse work in the other ones?

  Black_Rain 19:23 18 Dec 2008

nope. I have tried it in the other ports and the red optical light doesn't even come on.

Last night I was looking at BIOS settings to see if I could figure anything out in there, and my ipod that was connected to one of the usb ports kept saying "connected" then it would say "disconnecting" and it kept alternating back and forth.

My motherboard is the ASUS crosshair (the first one, not the crosshair II)

I have an athlon 64 5200 processor

2gb ram

2xevga 512 geforce 7950 SLI graphics card

and i am running windows vista ultimate

erm...perhaps that would be useful?

  tullie 19:30 18 Dec 2008

Have you tried deleting all references to usb devices in control panel,then rebooting?

  Black_Rain 19:31 18 Dec 2008

yep -_-

  oldbeefer2 09:02 19 Dec 2008

Worth a look in device manager to see if the drivers are OK?

  iscanut 11:18 19 Dec 2008

Have you a USB hub that you can plug into the one port that is working ?

  Black_Rain 18:15 19 Dec 2008

well, actually, that was one of the first things I have tried.

I looked in device manager, all my ports were working according to that.

I uninstalled all usb devices

I rebooted.

Nothing. grrrr....

I actually gave up on them last night, and ordered a usb pci card from newegg.

really, it isn't so much the fact that I have been reduced to one usb, but i would just like to know why they aren't working, you know?

I'm assuming it is because they got shorted out or something.

  smoking44 21:25 21 Dec 2008

If you have let vista do all updates then you might have a conflict of system bus drivers.

I have had this fault a few times with a vista install

Look in Device Manager/Universal Serial Bus Drivers.

You can disable or delete one at a time to see if that is the faulty one. Worst that can happen is a reboot and a manual enable.

  VOT Productions 20:56 01 Jan 2009

Update USBs then restart
Many times that can be solved

If you did roll back USBs

  boarg1 18:49 03 Dec 2010

have you got Kaspersky I/S product,try:-

click here

I have had USB failure for several weeks and was told by

the motherboard suppler that it was broken,
I got a s/h one and installed it, USB still not working.
All fixed now

Use kaspersky special tool to completely remove KIS,

delete all your USB and reinstall KIS

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Adobe shows still-in-development tools, including automatically colourising black-and-white photos

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?