Help me swap over mSATA drives

  Bailey08787 11:41 08 Apr 2014
Locked

Hi

I own a Dell XPS 15 9530 that came with Windows 8.1 pre-installed on a 32gb mSATA. It's OEM, so no windows discs

I wish to substitute the 32gb mSATA with a 240gb mSATA, but I'm not having any luck doing so.

I initially attempted to do this via the Dell Backup and Recovery system, making a recovery disc on USB and creating a system image on a 500gb usb drive. However when attempting to do this, the Dell Backup and Recovery doesn't recognise the system image / won't let me proceed.

So I next tried doing it the windows way, making a recovery disc and creating a system image. However windows then prevented me from booting / restoring the system image, saying it was a EFI (or UEFI) system image and that Windows could only restore a BIOS image.

I've also previously tried the whole process above using Paragon Disk Manager 14, but without success.

Does anybody know where I'm going wrong?

thanks

  JamieStewart 13:58 08 Apr 2014

I recently did something similiar only with an HP laptop, hopefully this can help you a bit cause I had nothing but trouble trying to set it up! I think this was mostly due to the UEFI settings in the BIOS which are quite hopeless.

My laptop came with a 1TB hard drive in it but part of the reason I bought it was because I knew it was possible to add an msata drive as boot and keep the 1TB as storage. I found a guide for a different model of laptop, still HP, and it helped but didn't cover everything. This is to do a clean install on the msata and wipe the old system I had on the HD.

Here's the guide 1">[click here program used to make a bootable USB was called Rufus. I imagine the situation with the intel drivers is probably the same, you should be able to get them off the DELL website.

Link to the version of Windows 8 I used is here 2">[click here

I know you've got 8.1 so you might need another iso. The Windows key on my laptop is built into the BIOS, I used a program to find out what my key was then tried to use that to download Windows the official way but as it was OEM I kept getting error messages. The iso I linked is for an RTM version of Windows 8, it automatically got the key from the BIOS and I was set up with my offical licensed verion of Windows 8, I then ran all of the Windows updates and upgraded to 8.1 for free in the Windows store. My only problem now, and it's not a major one really, is that if I go into the BIOS it pretty much stops Windows from booting. Only way to fix it is to remove my HD and fix the boot from msata. Shouldn't affect you though. Anyway, hope this helps, I was pulling my hair out after a few hours trying to get this to work! My laptop now boots in about 17 seconds I think which isn't far off my desktop! The

  rdave13 14:09 08 Apr 2014

Instead of creating an image with Paragon have you tried a direct 'cloning'. Connect the 240 GB drive via usb caddy and clone the C drive to it. Change the drives over and see if it boots. If ok you will need to extend the C partition.

  Bailey08787 14:51 08 Apr 2014

thanks Jamie Stewart - why do they make these things so flipping hard eh?!?

thanks rdave13 - that sounds like the most painless solution - i'm going to give that a go - have just ordered this

  Bailey08787 10:02 10 Apr 2014

hi again

so i've cloned the mSATA drive, swapped them over, and all is booting okay.

However, two new issues: - 1) Its telling me Intel Rapid Start Technology is no longer enabled (and it's greyed out in the bios)

2) My 1TB HDD is no longer visible in explorer / disk manager

To provide additional context, when I cloned the original 32gb mSATA drive containing the OS, I believe it was in RAID configuration with the 1TB HDD - in fact it must have been, because the size of the cloned drive was around 150gb.

So my queries are: a) How do I get Intel Rapid Start Technology starting again b) How do I get my 1TB HDD back c) (and ideally) How do I bring the size down of the cloned drive (presumably I can just find and delete everything bar the OS files)

thanks!

  Bailey08787 17:38 11 Apr 2014

Anybody?

  rdave13 18:16 11 Apr 2014

To be honest I'm not up to speed on UEFI or if the setup is Raid 0. So I'm suggesting only what I would try. First thing is, is that the clone size is incorrect and you seem to have lost the Intel® Rapid Start Technology driver. So the actual cloning didn't clone accurately. Check Paragon, when cloning, what choices you have and omit nothing. So I would see if you can connect the original SSD again but this time disconnect the sata drive. See if it boots up. Then I'd have a go at cloning the drive again. Just suggestions to try, and bumping the thread for others to see.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

How to update iOS on iPhone or iPad

Les meilleures applications pour enfants 2017