Help - I keep losing Google Earth.

  ened 15:21 26 May 2009
Locked

Yesterday I was reading a thread about GE beta.

I am sure that all I did was to click on Help/about in order to see which version I was running.

However when I booted up this morning GE had disappeared from the Start Menu (Vista Ultimate 64). When I clicked on Search all that was showing was the .exe file for installation.

I did a System Restore which put it back on the Start Menu but when I tried opening it, it started up then closed immediately with the usual message.

I went into Add/Remove and it removed it then I reinstalled it.

It worked until I rebooted then I was back to square one.

So I tried downloading the latest (V5) and as soon as I rebooted it refused to open.

I don't have any other problems with my computer so am at a loss to explain this.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?