HELP WITH EPSON R300

  JETYS 12:07 26 Sep 2006
Locked

Had the printer about a year. It prints text files ok, but has problems with any kind of graphics ie it starts to print the first few centimetres very slowly and hangs up.

I have been to Epson technical support and after many helpful options they suggested a new printer which I don't feel is the answer. I have got latest drivers and re-installed several times.

My feeling is that one of the many XP updates has changed way the printer is working.

The printer is on a virtual usb port if this of any help.

I am completly baffled and no one else seems to have the problem

  Stuartli 12:47 26 Sep 2006

I have an Epson R300 and XP updates certainly haven't affected its performance.

Could be that one or more cartridge inks are blocked up if you don't use it all that often. I leave mine switched on virtually permanently as it's supposed to prevent such problems.

Certainly, even using low cost compatible cartridges, it prints perfectly whenever I use it.

  jbaker65 12:48 26 Sep 2006

Did you remember to uninstall the old drivers before installing the new ones. Sorry but that is the only thing I can think of.

  Stuartli 12:48 26 Sep 2006

Doesn't Epson offer a replacement new printer at a one-off cost of £45?

  Bagsey 14:31 26 Sep 2006

I had a similar problem a couple of months ago and tried all manner of cures. Eventually in desperation I found my printer installation disc and reinstalled it over the top and it worked. So try that if you haven't already.

  JETYS 15:23 26 Sep 2006

I do leave the printer off when not using, but go through the printer clean head action several times and to no affect.

Have removed the drivers several times and installed latest update. Have not tried using the original Epson disc, but have always used latest drivers since using printer.

Epson did not offer a replacement, as they and I concluded that it is not the printer at fault.

I have printed out this forum, and it took two minutes to print the graphics ie the post response at the bottom, any other graphics just take ages and then the jibberish ascii text after waiting ages.

  Bagsey 17:38 26 Sep 2006

Can you remember when all this trouble started??? Perhaps a System Restore to before that time might be the answer, especially if your trouble is the result of something that you put on to your computer???

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?