HDD/BIOS help!

  potatological 07:04 17 Mar 2013

My bios isn't listing my hard drive as a bootable device. I have no idea what's wrong! When i start my computer up i get this message:

The current BIOS setting do not fully support the boot device. Click OK to enter the BIOS Setup. then in yellow text: Go to Advanced>Boot>CSM Parameters and adjust the CSM (Compatibility Support Module) settings to enable the boot device.

But not only do i have no idea how the hell to set those parameters, i'm completely unfamiliar with this Asus chipset motherboard and it's drivin me nuts!

Please anyone help me out? Took my computer to geeksquad and they told me i need to order a factory restore disk from Asus and i can't even call till monday to inquire about it! It's been a week of me trying to figure this out and i am literally

Thank you in advance for any help!

My computer model: Asus CM1745

Upgrades i have made: 520 WATT Dynex PSU model: DX-520wps HD Radeon 6870 GPU

  Chronos the 2nd 08:22 17 Mar 2013

Have you tried the simple process of another Sata data cable, oddly enough I had a similar problem myself recently and the reason was a faulty cable.

You could also try within the BIOS of resetting to defaults.

Is this your PC? and is this your motherboard?

  potatological 08:45 17 Mar 2013

Yes that is my PC, unsure if that's my motherboard but certainly looks like it! I have tried switching the data cables from my DVD drive to my HDD because i only have 4 data cables in the computer (unless you're talking about the ones that stem from the PSU?) and two of them are plugged into the motherboard.

  potatological 08:46 17 Mar 2013

Also i have tried resetting to optimized defaults and did nothing

  Chronos the 2nd 09:24 17 Mar 2013

No I am not talking about the ones from the PSU as they are power not data. So unlikely to be the sata cable if you have tried another.

I have had a Google about your error message and there does not seem to be anything definitive except that the problem always seems to occur on Asus board. I use Asus boards most of the time in my builds and know that usually they are quality.

Can you tell me when this problem first occurred? I presume it was working fine up until this point? What is your OS? If Windows 7 have you set the drive controller to AHCI if you have reset then it is likely to have changed to IDE which will mean you will not be able to boot your PC.

  potatological 09:33 17 Mar 2013

First occurred after i was messing around in the BIOS trying to get the CD/DVD Drive to boot before the HDD from then on it just hasn't been wanting to boot! I'm running windows 8.

  Bris 09:54 17 Mar 2013

take a look here at the paragraph "disk device compatibility". I have just taken a very quick look at this but it occurs to me that perhaps your HDDs are formatted with a MBR but that the BIOS is set to find a GUID partition table in which case I assume it wont find one and therefore the message you are getting.

Could be wrong of course.

Also are you saying this has occured since you did the upgrades?

  potatological 10:07 17 Mar 2013

So wait what exactly should i do to solve this? I did no upgrades i was using a registry wipe disk so i could access my user again because i forgot the password to the admin account

  Chronos the 2nd 10:23 17 Mar 2013

Have you tried to install windows 8 again, I am sorry if the questions seem random but just trying to get as much info as possible.

So you were trying to change the boot sequence to DVD to reinstall Windows and from that moment on you have had problems?

Have you tried clearing the CMOS? Have a look here. But you still need to change the drive setting to AHCI after the reset.

  Bris 10:24 17 Mar 2013

Cant help much as I dont have a UEFI BIOS but from your original post the message suggests that if you follow the path suggested you can change some parameters, have you tried that? Come back with the parameters and perhaps we can help.

You said that the problem occured when you tried to change the boot order. Its possible that its trying to boot from a flash drive for instance thats not bootable.

Have you got the boot order correct?

  Bris 10:27 17 Mar 2013

Sorry Chronus, both posted at the same time.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?