HDD in external Caddy - No Drive Letter Assigned

  onthelimit1 17:48 20 Feb 2014
Locked
Answered

Done this lots of times before with no snags, but stuck with this one.

Plug laptop working hdd into caddy connected to pc running XP. Drive does not show in My Computer. Looking at Disk Management, the drive shows with correct size, but has no drive letter allocated. Can't find a way to do so.

Any thoughts please?

  Fruit Bat /\0/\ 19:17 20 Feb 2014

click on the blue section of the partition and then right click and select allocate drive letter from the menu

  onthelimit1 09:46 21 Feb 2014

Tried to do that, but the options are all greyed out. Managed to recover the data with the HDD back in the laptop using HPs W8 recovery, but would like to resolve this if poss for the future.

  Fruit Bat /\0/\ 11:01 21 Feb 2014

is the drive showing as

active or dynamic?

  onthelimit1 13:53 21 Feb 2014

Hi FB. It shows as 'Healthy (GBT Protected Partition)'.

I've tried a couple of other HDDs which show as D straight away, and as Active. The one in question is a 3Gb Hitachi from a Windows 8 laptop.

  Bris 18:13 21 Feb 2014
Answer

Sure its not GPT and 3TB?

If its 3TB then in order to realise the full 3TB it looks as though its been formatted with a GPT (GUID Partition Table) rather than a MBR.

If the PC you are trying to connect it to doesnt have a UEFI BIOS or the OS is 32 bit that would explain why its having problems with it.

I believe that a GPT contains a protected MBR within it but not sure on this.

click here for some info but its a bit heavy going.

  onthelimit1 12:03 22 Feb 2014

Thanks Bris - it's only 300Gb, but the PC OS is 32bit. Laptop back with owner now, but I'll bear in mind the points if this happens in the future.

  Bris 13:32 22 Feb 2014

My pleasure.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?