HDD Bust!

  BaboonBoy22 19:48 16 Aug 2009
Locked

For some reason my sata drive has stopped working. When I try to open it says that the drive is not formatted!!!
I've taken it out and tried getting into it using a sata dock, but nothing.

Is there anyway that I can get to the data on the drive? (It's not backed up as the files are too large).

  howard64 20:05 16 Aug 2009

I use easus data recovery and it can recover all your data. There are good free ones available - google 'free data recovery'

  BaboonBoy22 20:11 16 Aug 2009

Thanks howard64, can you or anyone else recommend any freeware? The last thing I want to do is get one that has a load of spyware built in

  Fruit Bat /\0/\ 20:35 16 Aug 2009

Ron chkdsk /r on the drive or right click
My computor - select drive - properties -tools tab - error checking

  BaboonBoy22 20:50 16 Aug 2009

Hi Fruitbat.. tried that, nothing happened.

I've now put the drive back into my computer, and it's not even showing up at all now, i.e I can't see it in my computer

  [email protected] 21:15 16 Aug 2009

Drives break - and stop working :-(
When this happens that's it unfortunately.
If you want to recover any data it can be done professionally but it is very expensive.
If you mount it and the PC doesn't see it then finalise it with a lump hammer and sling it. Or take it apart yourself just to see how they are made...
There is a difference between recovering data from a HDD where the data is corrupt and one which doesn't work, which is what you appear to have.

  DieSse 21:30 16 Aug 2009

(It's not backed up as the files are too large).

Well I guess now you know how essential a backup is. There's no such thing as a file too large to back up. If your data is important .....

Sorry.

  BaboonBoy22 21:56 16 Aug 2009

i can see the drive when i have it in the dock. which is when i get the message to format it.

All my essential files are backed-up.. this drive is for my movies which I use as temp storage before i put them onto disks. I have around 250Gb+ on there at the moment. I could have forked out on a TB drive and backed up the lot, but as my usage of the drive varies I didnt see the point

  DieSse 22:09 16 Aug 2009

Try taking the drive out of the caddy - perhaps the caddy itself is faulty, it happens.

if it can't be seen by the BIOS when attached internally to the system, then it's kaput.

If it can be seen, then you can run some tests etc. Course of action then depends on what happens.

  DieSse 22:10 16 Aug 2009

Or did you mean it already can't be seen internally? (got a tad confused as to where it was originally).

  Colonel Snow 23:18 16 Aug 2009

Have u tried testdisk...its free program you can download and its got a good data recovery on it.....plus it can rebiuld the master boot record etc.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?