Hardware problem

  floyd 768 19:04 14 Mar 2004

I had a problem installing my digital camera on my p.c. using xp. It would detect the new hardware try to insall it then it would say cannot install hardware , usb device, an error occured and the data is invalid. When checking device manager there was a yellow exclamation mark next to the device. After writing a thread about this problem it was recommended that i bought a card reader which i did . I also bought a webcam and decided to install the webcam first. Would you belive that i have exactly the same problem . It seems that i cannot install new hardware, bought hardware that has previously been installed like my printer works fine. Please help.

  VoG II 19:08 14 Mar 2004

With USB devices you normally have to install the software before plugging the device in. Apologies if that is what you did.

  floyd 768 19:23 14 Mar 2004

Yes i did do that thanx anyway

  floyd 768 16:28 15 Mar 2004


  Gemma 16:53 15 Mar 2004

How many USB devices have you? How are they connected? How are they powered?

  floyd 768 19:28 15 Mar 2004

I have two printers running off two usb ports in the tower.

  JJCUK 19:55 15 Mar 2004

Have you tried
right clicking on the exclamation mark
selecting properties
then upgrade driver
and browse to your cd or floppy ?

  IClaudio 20:19 15 Mar 2004

If you want to run so many USB bits of kit, try a USB hub. Make sure that it is powered, PC World will do a powered 7-port hub for c.&25, last time I looked. The card reader should be happy when plugged into the hub, and probably the webcam too.

You don't mention Broadband - if you have a BB modem, that should run off your motherboard, not the hub. I think your printers will be happy running from the hub, but maybe you should not tempt Providence and run one of them from the motherboard (?TWO printers?:))

Good luck...


  canute44 20:51 15 Mar 2004

Sorry to butt in. What is wrong with having two printers?? I have a colour one for photos etc and a laser b/w duplex one for every day use! Doesn't every one??

  floyd 768 22:19 15 Mar 2004

Thanks for your reply tried that same problem. IClaudio, I have a 4 port usb powered hub which had my camera and a printer plugged into. When i noticed the problem, i removed the hub incase that was causing the problem. I tried it in both usb's in the tower but still the same problem. Yet my printers work fine in both usb ports.

  JJCUK 02:38 16 Mar 2004

Have a look here for a start

click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 Hack Latest News: How Secure is your Wi-Fi?

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Best kids apps for iPhone & iPad

Comment utiliser Twitter ?