Harddrive won't format

  Harrier man 17:20 24 Sep 2004
Locked

I installed 2nd harddrive, made it the master and successfully reinstalled Windows and all software. Intended original drive to become the slave and have changed the links. Tried to reformat it and there appears to be some disc activity but bars do not appear to indicate formatting taking place. Tried to format drive under the command prompt but the initial action to verify remains at 0%. At one point I got the error message, 'cannot format drive'.

How can I force the drive to format? It was usuable before I added the second drive.

  Dorsai 17:35 24 Sep 2004

Did you remember to set the old drive to slave?

Is the Bois detecting the old drive corectly?

Can you see the drive in wondows OK? If so, perhaps just delete the files on the old drive, and then use it?

first guesses..will think on it.

  Harrier man 20:15 24 Sep 2004

Old drive is set to slave and is visible in Windows Explorer/My Computer. Clicking on it produces the message, 'drive not formatted, would you like to format it now'. If I try to format by clicking 'Yes', I get the same result, ie it will not format.

If I look under Device Manager, both drives are shown.

  Gongoozler 20:24 24 Sep 2004

Hi Harrier man. Are you using Windows XP or another version? Is your file system FAT32 or NTFS?

  THE TERMINATOR 21:01 24 Sep 2004

you need to fdisk your new drive click here ....TT

  Harrier man 16:57 25 Sep 2004

I am using Windows XP (always have, machine is 2 years old).

Cannot fdisk as suggested. Get eror message'disk is not recognised as an internal or external command operable program'. Knowledge base article referred to by The Terminator suggests it only applies to Windoze 95, 98 and ME.

What next please?

  Gongoozler 17:17 25 Sep 2004

This is how to do the job in XP click here

  Harrier man 19:05 25 Sep 2004

Followed this and started the formating. Things appeared normal when I started but after 1hr 10mins the status line says its just 2% complete. Surely this cannot be right? The drive is a standard 60Gb Maxtor drive.

  pj123 19:14 25 Sep 2004

If it was mine I would download a bootdisk from click here (use the Win98se bootdisk) and make a floppy bootdisk. Change the BIOS to start from floppy first. Put the old disk in as master and use the boot floppy to Fdisk, Partition, and Format it. Once that is done put the new disk back in as Master and the old disk as Slave and reboot.

  Djohn 19:15 25 Sep 2004

It does seem a long time for the format. I would have thought around 45 minutes for a full format of 60GB drive as it does a check for bad sectors as well.

If you know the drive to be OK then try a quick format which will take less than a minute, at least it will confirm if the drive is able to format without waiting for such a long time.

Right click My Computer/Manage/Drive manager. You will see both drives from there. C Drive will be Disk 0 - slave drive will be Disk 1. Right click in the right hand pane of the slave drive, from the options choose format/quick format. See if that helps.

  Harrier man 19:27 25 Sep 2004

Touch wood something might be going right at the moment. I deleted the partion, reinstated it and did a quick format. That looked okay. I have now just started a full format so will come back in about an hour to see if all went to plan. Thanks for all your help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?