Hard drive problem

  Skuby 20:14 04 Apr 2007
Locked

Hi, I have a PC with two hard drives, 250Gb master & 80Gb slave.
Everything worked perfectly until I tried to install Win98 as a second operating system. In error it started to write on the 250Gb master but almost immediately stopped. Since then it would not boot up. I have managed to retrieve most of my work by putting the drive as a slave, installing XP on another drive and retrieving my work.
The problem is I can no longer boot from this drive, it has been formatted & re-partitioned. Also when the PC is switched on and BIOS checks the IDE channel, this 250Gb drive is very slow to respond (approx 2 minutes), it has SMART enabled & has never reported any errors.
It seems to work ok as a slave drive but not as a master, and yes the jumpers are set correctly.
Any ideas???

  woodchip 20:19 04 Apr 2007

You will not be able to put 98 on a computer that as XP on the C:\Drive. AS 98 wants the C:\drive It will work the other way round 98 first XP after

  mosfet 20:27 04 Apr 2007

Sorry to contradict woodchip but you can indeed have XP on C: & 98se on D: This PC is Just that. Just that XP should be installed last.

  woodchip 20:30 04 Apr 2007

Try telling him how to do it

  mosfet 20:41 04 Apr 2007

Simply install 98 on D: then install xp on C:
xp only needs to go on last for the boot menu.
If bootmagic or other bootmanager is used it would'nt matter.

  Skuby 20:45 04 Apr 2007

Hi woodchip & Les, I am now trying to get XP back on my 250Gb drive and be able to boot from it, am not going to put Win98 on now.

I am just baffled as to why i can't get it to boot from it.

  woodchip 21:35 04 Apr 2007

Les2 seams to know all the answers

  Skuby 20:42 08 Apr 2007

Why does the drive work ok when used as a second drive, but when connected as the master it hangs at boot up, takes approx 2 minutes before the black boot up screen displays the IDE drives and cannot be used? It displays it almost instantly when a slave drive.

The jumpers are set correctly & accordingly, it is a Western Digital 2500JB - 250Gb.

Any help would be appreciated as this has got me beat!!

  woodchip 20:47 08 Apr 2007

If you are changing two drives round and the one you set as slave, as the original OS on it, the BIOS is looking for a Operating System in the MBR of drives. By awaping them round it cannot see the disc

  Skuby 20:58 08 Apr 2007

Hi Woodchip,

This drive used to be the master running XP, no probs with it until accidently started to install Win98 onto it.

Tried to re install XP - no joy. Fresh install of XP but then kept coming back with errors saying can't write various files (.dll's & .sys files) to hard drive for installation.

Used Western Digital installation CD to re-write MBR & then format, all seems to go ok.

Still won't allow XP to be installed & hangs at boot up & is un-useable.

Put as a slave & it is fully accesible & is recognised by BIOS at boot up almost instantly.

  woodchip 21:03 08 Apr 2007

Was XP on a Fat32 before you tried loading 98 or was it NTFS? as they are different formats for the drive. And you cannot mix them . It sounds like you need to clear the disc with Killdisk click here and start from scratch

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone