hard drive problem

  the kopite 11:37 07 Apr 2006
Locked

Hi Guys My hard drive has just started to act strange when I boot up I keep geting boot disc failure insert sys disc so I have to remove my battery then reset the bios date and it boots fine I cheked in the bios and all discs are set to auto so I tried WD lifeguard and it says bad clusters maybe it can be repaird but I guess that means returning the disk to zeros and this is what I dont wish to do any ideas please I am a bit worried about flashing the bios as one failed on another motherboard kopite

  steve12345 11:45 07 Apr 2006

Looks like your HardDrive is on it's way out, I'm afraid. If I was you, I would back up the data on that drive when it's working and get a new one. Dont wait too long or it may be too late, the drive may refuse to work permanently one day.

Flashing the bios wouldn't have any effect so don't do that if you don't need to for other reasons.

  the kopite 12:10 07 Apr 2006

Hi steve I tried a new hard disk with the same results and done a check on my old hard drive that shows only six bad clusters ? which windows now reconises and will not try to write to thanks kopite

  ed-0 12:37 07 Apr 2006

98 or XP?

98; restart in dos and do a full scandisk. Windows will mark the bad sectors and not write to them. Defrag after.

XP: right click the drive > properties > tools > error checking. Put a tick in the boxes for " auto matically fix file system errors" and " try scan and attempt to recover bad sectors".

See if this helps.

  Diemmess 13:30 07 Apr 2006

"I tried a new hard disk with the same results"
~~~~~~~~~~~~~~~~~~~~~~
This suggests to me that the problem is not the old HD itself, rather something else which causes that boot disk error.

Things to try

RAM troubles can have a part in this, but unless you have interfered with the RAM recently don't bother now.

Try a minimal PC - disconnect every peripheral except the old HD, and then try booting. Also if you have fiddled with RAM this is a good point to go back to what you used to use.

If you have a '98 startup floppy try booting with that to see if it reacehs the A:> prompt.

Try a substituted data cable from the mobo to the HD.

  the kopite 13:32 07 Apr 2006

Hi ed-o I done that I have XP but formatted the hard drive in fat 32 for other reasons done a full scandisk check and it found the 6 bad clusters but the problem still remains ie losing the hard drive on boot up thanks kopite

  the kopite 13:38 07 Apr 2006

hi diemmess yes it boots to a floppy gets as far as telling me about no fat 32 partion but will not allow me to try fdisk which I dont wish to do anyway. I have it going now which is how I have done scandisk check/all but when I switch off I will have to reset the bios again to get it to boot up Kopite

  Diemmess 15:56 07 Apr 2006

I'm still a little fuzzy about what you have done/not done.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
"so I have to remove my battery then reset the bios date"
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

It shoudn't be necessary to have to go into the BIOS and reset the clock. Removing the battery will of course reset to the defaults, but if the battery is dead - replace it, set the clock and leave it alone next time. It is possible that a failed battery might cause most of this, some mobos are more sensitive than others!

You have checked the HD is recognised, and saved any BIOS changes at the end....Yes?
Have you checked the first boot device which might read Floppy or HD0?

If you boot with a floppy the process will end with A:> nothing else.
If you are still getting "boot disk failure:Insert system disk" then it is still trying to boot from the HD. Very rarely this will happen with a healthy system but a nifty reboot usually solves the problem.

Like Steve1234 says, I would back up data when/if you can, then take the precious old HD out, pop the new one in and go through the whole process of installing XP. (in that event make the CDROM first boot device.)

Once this is up and running, you can hang the old HD in as a Secondary HD, and transfer any other things you left behind last time!

  the kopite 17:12 07 Apr 2006

hi dimmmess If you remove the battery the bios resets date time year I have checked the bios and everything is correct but what makes me think its the bios is the fact that I am getting the same symptons with a new Hard Drive if it was the drive then the new one should have sorted it. When it say insert system disc well that is no good as far as the computer is conceaned there is no hard drive thats why it will not go to the A prompt. Checked boot disc start up in the bios that is correct I am stumped lol Thanks Kopite

  Fruit Bat /\0/\ 17:44 07 Apr 2006

1. check IDE ribbon cable is fully inserted at HDD and At motherboard.

2. It may be worth swapping the cable with the one for the CD/ DVDs

If the problem goes away then it is probably a faulty cable.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?