Hard Drive not recognised

  plkiojh 20:07 06 Feb 2004

System - PC Chips M848 mobo - Athlon XP2400 - 512Mb DDR 333, Western Digital HDD, running XP Home.

I recently rebuilt the system round the new mobo and processor. It workd fine other than at startup the HDD is not always recognised. If I enter the BIOS and set HDD to user, then use Auto detect, the HDD is recognised. I then have to re-boot, re-enter BIOS, set 1st boot device to IDE-0, as it is not present at first boot, save and exit. Upon re-booting, the HDD is recognised, and the system will start.

However, there is a long pause each time I save and exit to anything happening (30 seconds or so) and when the splah screen appears, it is dim for mabey 2-3 second, then all is well. Windows upon startup reports that the system has recovered from a serious error. Everything then runs as it should.

Is there a way to make the HDD recognised at first boot without having to go through the above procedure, or do I have a faulty mobo as I am suspecting?

  Diodorus Siculus 21:02 06 Feb 2004

There is an option for a "fast boot" somewhere in the BIOS - disable it as it may be so fast that the hdd is not spinning fast enough at startup.

  Diodorus Siculus 21:33 06 Feb 2004

Disabled quick-boot. All that happened was a longer RAM check. The system will recognise the HDD from a powered re-boot, but not from a cold boot.


It's best to conduct these discussions via the threads; that way others can chip in with their experience and knowledge.

  gold 47 21:45 06 Feb 2004

Also check the jumper on the drive is set correctly IE Master or slave and not set on cable select.

  plkiojh 21:52 06 Feb 2004

Jumper is set to Master - I never mess with cable select. I also tried 2 other IDE cables (all 18" or less) - same result

  Djohn 21:54 06 Feb 2004

Also, because you have set your 0 drive as first boot, check that you have set your CD drive/s and floppy to boot as second and third drives. If you have left your CD drive as first boot as well and the BIOS on auto, it might just be confusing it. j.

  Faser 22:04 06 Feb 2004

I recently spent hours on a similar problem that turned out to be caused by a poor cable connection. Suggest you remove and refit the IDE cable (both ends)and the power plug.

  gold 47 22:13 06 Feb 2004

Try going to device manager click on the harddrive
and uninstall the driver and reboot it should reinstall your hard drive.

  plkiojh 22:23 06 Feb 2004

Tried refitting IDE cable and power cable. Same problem. Interestingly BIOS screen and Windows are both telling me I have a 2.14Ghz Duron and not an Athlon XP2400.

  plkiojh 22:31 06 Feb 2004

Reinstalled the HD driver - still the same

  jimv7 23:11 06 Feb 2004

Remove the 2nd drive from ide0 and connect it in place of the cd drives on ide1, then try to boot and see what the bios makes of it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?