hard drive found smaller

  dazzlet2004 23:54 03 Jun 2008
Locked

hi i have a 300 gb hard drive which i want to use as a slave drive for storage and backups and such but when i have put it into my pc the hard drive is found in dos and all comes up ok but in windows it shows as a 135gb hard drive not a 300 how can i fix this i have had a look in the administrative tools in the disk managment part but it only shows as 1 drive with 1 partition and all the space is supposedly used byt the partition but i know it isnt really as the drive is 300gb and only shows as 135 please any advice would be great thanks

  sean-278262 00:53 04 Jun 2008

click here

You never told us what OS you are using so I will have to assume you are running XP.

Also I assume you mean the B.I.O.S. or the POST not DOS. BIOS is the blue screen you access by pressing either f8 or the del key. The post is the first bit of activity your computer displays when it turns on usually listing the drives and running a memory test.

A

  Dragon_Heart 03:20 04 Jun 2008

Some older versions of Windows i.e. 3.1, 95 & 98 could only recognise drives up to a certain size. You may be able to get a fix off the hard drive manufacturers web site.

  Diemmess 09:39 04 Jun 2008

Is the HD new and straight out of the box, or has it been used somewhere else before you had it?

I'm wondering if it has been in use before and a "hidden partition" exists, or for some reason only part of the HD was allocated to that drive and the rest is unallocated and unformatted.

If you can get hold of a copy of Partition Magic, the whole HD can be sorted in a very few minutes, but expect to lose any data not squirreled away first.

  UncleP 11:07 04 Jun 2008

You give too little information for a definitive answer, but I think 137Gb was the maximum HD size set by an out-of-date memory address bit length. Anyrate, all explained in this earlier thread
click here

  Fruit Bat /\0/\ 17:00 04 Jun 2008

Are you running Xp SP1, as this problem was addressed by SP2?


In Windows, click on Start->Run, enter "regedit".
# Navigate to the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters registry subkey.
# From the Edit menu, select New, DWORD Value.
# Enter the name EnableBigLba, then press Enter.
# Double-click the new value, set it to 1, then click OK.
# Close the registry editor.
# Restart the machine for the change to take effect.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?