Hard Drive Format Greyed Out

  johndrew 10:04 16 Oct 2007
Locked

Bit of a long tail but it may help any that try to help.

I had problems with the second SATA HDD (a Maxtor 6Y250M0) which I use for storage/backups; it was divided into two partitions. I checked with CHKDSK found it dirty and went for the recovery option; this failed with an i/o warning. Went for the option to reformat which appeared fine but when I tried to `Delete Partition` it refused.

I loaded the SeaTools floppy and used the Z (erase track 0) option. Whilst I was at it I did a check of the drive and it came back as `good`.
I then went to the format option, which loaded the Wizard, and set the drive up as a single primary basic NTFS partition. This can be written to and read from.

I now have the need to divide the drive back into two partitions but both the `Delete Partition` and `Format` options are greyed out. This applies to both drives.

Can anyone please help me regain the facility and tell me where I went wrong?

Many thanks in anticipation.

  McD 10:33 16 Oct 2007

Haven't used SeaTool! but try this (XP or Vista OS): Right Click My Computer >Manage> Storage> Disk Management> this should show what disks are active. Try formatting from here. If it wont let you format, you will have to go into the BIOS and disable the drive. Then retry.

  johndrew 11:50 16 Oct 2007

I have been attempting to format from Computer Management - the primary area as I understand it - with no success. The only other way I know of formatting is to right click the disk icon, but that doesn`t work either.

Can you tell me what disabling the drive in BIOS will do? Surely if it is disabled then it can no longer be accessed at all?

  McD 11:56 16 Oct 2007

If you disable it in the BIOS, it will not be "seen" when the computer boots up. So it will not be active in any way. When you go into disk management, it will recognise that there is a drive there, but not active, so you should be able format it. After it formats - go back into BIOS and reactivate, and when you boot up, the new hardware wizard should start and install the drive. Hope this helps.
McD

  johndrew 16:22 16 Oct 2007

AaaaH. I see your logic. Worth a try. Question is will it resolve it permanently, have to try and see.

  johndrew 16:27 17 Oct 2007

All very confusing.

The only options available appear to be `Auto` which shows the drive in BIOS or `None` which is exactly what it says on the tin.

In `Auto`, the original setting, I can only boot into Windows with an unformatted drive. If I then format the drive and put some data on it, the PC hangs at boot. If I disconnect the drive, delete the start track or select `None` I can boot into Windows.

I have tried with a brand new drive as well with the same results. It seems that the motherboard is happy looking at one drive, but not more than that if it (they?) have data on them. Could it be that for some reason the PC is trying to boot from both or the content of the drive is confusing it?

Any suggestions where I go from here?

  pj123 17:08 17 Oct 2007

Try Maxblast 5

click here

Download it and make a CD. Reboot from the CD.

Should do what you want.

  johndrew 20:08 17 Oct 2007

The New drive I installed was a Western Digital to match the boot drive (just in case there was a conflict).

The problem remains exactly as in my last post, last paragraph.

Would Maxblast do in good in this case, I already have SeaTools for the Maxtor drive and WDs DLG Diagnostic disk?.

  johndrew 15:20 21 Oct 2007

After a lot of trial and tribulation the problem has been resolved, but I`ve no idea what the fault was. It took two attempts using the Windows `Repair` option (this because the first attempt left me with the same problem) and the obvious pain of over 100 updates to reinstall plus other tidying etc.

Both drives - the original Maxtor and new Western Digital are good - so I now have spare drive. If the PSU will take it I may treat myself to another SATA cable and plug it in.

Thanks for all your suggestions and help. Unfortunately I am unable to identify the cause of the problem, only how it was (finally) resolved.

  vector07 17:46 19 Jul 2008

Hiya,

I have a similar but not quite the same problem as the OP.

I have two hard drives. One is my old hard drive, one is my new, and they both have Windows XP on them. Now that my new drive is stable I want to format the old drive and use it as backup.

However, when I go to Computer Management the options for formatting the non-active secondary HD that has XP on it--the options for format are grayed out. So how do I format the drive?

  johndrew 10:02 21 Jul 2008

I should suggest you get hold of the drive manufacturers utilities (SeaTools in the case of Seagate/Maxtor), generally free from their site, and erase the track 0. Make certain you select the correct drive. You should then be able to delete/initialise, partition and format in the usual way.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?