Hard drive failure?

  bolo 22:02 17 Feb 2003

My pc crashed during norton speed disk and then failed to boot and has displayed the message "drive read error restart your computer" this is repeated on each reeboot. in desperation i used fdisk to start the reinstallation process, this kept restarting part way through but finally followed through. I then restarted my computer to format the hdd this began but soon i had the message "trying to recover allocation units" which proceded extremely slowly (I left it on all night)
Any ideas, is my hdrive knackered or is there a work around. I have tried formating as a slave in another drive but no luck.
Hard drive is a 40 gig 7200 100 ata IBM in a modern xp 2000 512 ddr system.

  wullie1 22:12 17 Feb 2003

norton speeddisk will not work with my xp pro
have you tried to reinstall windows? look like some bad sectors on hd

  bolo 00:27 18 Feb 2003

I am at the stage where i would love to install windows but the format is taking forever. it says its recovering lost units?

  DieSse 00:40 18 Feb 2003

Looks very much like the Hard Drive has gone to the magnetic graveyard in the sky.

It might be worth downloading the IBM Hard Drive diagnostic and "zero-fill" program. This tests the drive, and can set it right back to how it was when it left the factory. Then you will get the definitive results on what's wrong.

Deskstar drive fitness test dowload click here

  lisamaree 01:09 18 Feb 2003

click here

I would check the drive with drive fitness test.
The drive sounds like it has bad sectors and even if when formating is complete these sectors are allocated to another area of the drive it will slow the access to down. Never use a drive with bad sectors send it back under warrantee or just replace it.


  lixdexik 18:10 18 Feb 2003

I had a hhd failure a couple of weeks ago.. I had two drives in the machine, when the slave drive crashed it some how damaged the master drive and I ended up with exactly the problem you described, that it would not boot, the fdisk found and sorted problems, then the format took ages with the same messages as you describe, "trying to recover allocation units" I left it to get on with whatever it was doing and the drive now works without any trouble.. although I do not use it as the master drive, just incase.. when it was formated I ran scandisk and no errors were reported. two weeks on and still no sign of trouble.

Cheers Lixdexik.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

How to update iOS on iPhone or iPad

Les meilleures applications pour enfants 2017