hal.dll problems

  griffo 20:58 25 Aug 2005
Locked

my HP Omnibook Xe3 won't boot into anything, saying the hal.dll is missing or corrupt and needs re-installing. I've read previous threads and entered the Recovery Console (using an XP Pro CD from another of my PC's) and tried the recommended :-
expand d:\i386\hal.dll c:\windows\system32\hal.dll command but get:-
The system cannot find the file or directory specified. The above command seems to vary a bit in different articles, so I'm not sure if I'm using the right command with the right spaces etc.
Suggestions would be much appraciated.

P.S. any idea why my "view your postings" is disabled?

  stalion 21:03 25 Aug 2005

go here select h click here

  bluesbrother 21:04 25 Aug 2005

Hardware Abstraction Layer DLL, v. 5.00.2168.1

click here

  griffo 21:12 25 Aug 2005

Stalion - thanks for response, tried that, actually got it to respond this time BUT it says:
Unable to create file hal.dll ??

Bluesbrother - thanks but what's the point in downloading the file if I can't boot to install it? or am I missing something?

  bluesbrother 21:19 25 Aug 2005

Put it onto a floppy and copy it to c:\windows\system32

For info on copy command click here

  bluesbrother 21:28 25 Aug 2005

Posted that before I had finished.

You will need a startup disc first, I think you can use the win 98 startup click here You use the copy command when you have the a/ promt

  griffo 21:35 25 Aug 2005

BB - tried that, unzipped it using XP's unzip tool, then tried:-
copy a:\hal.dll c:\windows\system32 and it said "the system cannot find the file specified".
also tried copy a:\hal etc. and it said " COPY does not support wildcards or directory copies"

  griffo 21:42 25 Aug 2005

BB - Oh, can't I use the copy command in XP setup repair (C:\WINDOWS>)?

  Fruit Bat /\0/\ 21:45 25 Aug 2005

Hal.dll missing or corrupt
click here

  griffo 21:48 25 Aug 2005

BB - update:
typed A: to get an A: propmpt, then copy hal\hal.dll C:\windows\system32 (cos it was in a folder called Hal on the floppy) and it says 1 file copied. What do I do now please?

  griffo 21:59 25 Aug 2005

Update:
converted to C: prompt and typed exit. Allowed PC to select Start Windows Normally and it now says:-
<Windows root>\system 32\ntoskrnl.exe please re-install a copy of the above file.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Les meilleures enceintes Bluetooth à moins de 150 euros