Guest account cannot connect to internet

  Charence 16:31 07 Aug 2005

I've just setup a guest account however, it is not able to make a connection to the internet. It will work if the Admin account is logged in and connected to the internet, but I would like the Guest account able to make its own connection without the admin account accessed first.

I think it may be due to a problem with the ADSL modem software not starting, a RUNDLL error appears when logging onto the Guest account; "An exception occurred while trying to run "amecsa.cpl,RUN_DLL".

I've tried to start amecsa.cpl from RUN, however the same error message is displayed.



  Charence 18:04 07 Aug 2005

any ideas?

  mattyc_92 19:10 07 Aug 2005

Guessing you are using WinXP, and not Win2K do the following....

1)Logon as the Guest Account you have created (or the built-in one if that is the one you mean)

2)Right-click IE and select "Internet Options"

3)Click onto the "Connections" tab

4)Click onto your modem in the list and select the "Dial whenever a network connection isn't present". Make sure that this modem is "Set as Default" just below the radio buttons and click OK

5)Click onto refresh and type in your details

Hope that helps.

  mattyc_92 19:10 07 Aug 2005

PS. I think that it is the same in Win2K (can't remember as it has been a while since I have used Win2k)

  Charence 23:22 07 Aug 2005


Yes, I'm using Win XP and the built in guest account, sorry for not stating that earlier.

In the guest account, none of the modems are present in the connections box and the Network Connections is empty and due to the limited account, I can't add a connection. Also I think that the DLL which can't run is the one for my ADSL modem.

Thank you for your help, I've 'solved' the problem by creating an admin account which is able to connect online. It's an account for my relatives to use whilst I'm away, I've removed buttons that access My Computer, Control Panel, etc...hopefully everything will still be working when I return! :-)


  mattyc_92 09:36 08 Aug 2005

Try logging on as an Administrator and re-installing your modem drivers.

Then restart your system and login as the Guest account. Now do the proceedure I have posted in my previous post again.

Hope that helps.

  Charence 16:50 12 Aug 2005

Thanks mattyc_92!


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Black Friday Deals 2017

Black Friday Deals for Designers & Artists: Adobe, Apple, Corel Painter, Microsoft Surface, Wacom &e…

Best Black Friday Apple Deals 2017

Black Friday 2017 : date, sites participants & bonnes affaires