Group Policy blocking USB access?? Any ideas

  IanH123 16:47 13 Jul 2007

Hi Guys
Don't know how advanced you all are, but I have done a quick search on the forum and cant find anything. Anyway here goes, at work we have ordered 100 usb keys with encryption software pre installed by the vendor. When you put the keys into the machine as a standard user logged on to XP they can see the encryption software but when they run it its like they have read only access so they cant type password format the keys etc etc. We have now tried a second application with exactly the same results.
So I'm thinking as we have group policy's setup it must be some rights to the keys that are blocking the registry being written to or its trying to write to the C: drive.
Oh yeah if you run it as admins it works fine, and no giving all the users admin rights is not an option.
Most of the team have had a look at this but know one can work out a solution.
Any suggestion at all, I have trailed the Internet and haven't found anything last resort is a forum.

  brundle 16:49 13 Jul 2007

"standard user logged on to XP" - Administrator, Limited, Guest?

  IanH123 17:04 13 Jul 2007

Yeah its a standard user basic rights, added the user to Super users group but it still didnt work, if it helps we have tried two applications Istar.exe and the other is LOCK.exe both I am unable to find anything one the internet. We had a contracter here and he bought them for cheap, as they say you play for what you get.

  brundle 17:19 13 Jul 2007

No experience of corp. networks here, just wanted clarification - I take it the application works on a stand-alone XP PC? I know there's a GP setting which totally disables USB key access, but nothing beyond that. Are the keys FAT32 or NTFS?

  IanH123 17:45 13 Jul 2007

Yeah works on a standalone pc with no problems at all it is just and xp pro machine on a corp network with Policys in force to restric the users from braking there machine, but the guys who set the policys are unaware of anything that would block the users from running the apps. Also the Partition is Fat

Thanks for the questions anyway I have been going nuts trying to work this one out I have been in IT for 10 years and have never come accross one like this before noramaly there is something on the web somewhere to give you a clue

  brundle 17:48 13 Jul 2007

It may be down to the apps themselves, if they are not written to check for NTFS/network permissions perhaps that is where the fault lies

  brundle 17:52 13 Jul 2007

Try Truecrypt on a single key drive - you can copy the files across to the drive, set up an auto-executing batch file to mount the encrypted drive - try that and see if you have the same problems. click here.
Only Truecrypt.exe and truecrypt.sys are required on the drive itself

  IanH123 18:03 13 Jul 2007

Thanks I will give it a go

  brundle 18:11 13 Jul 2007

I use

%cd%\truecrypt.exe %cd%\ /lT /a

as a batch file to mount the drive, where the encrypted volume is, it automatically asks for the password then mounts the volume as drive T:

  IanH123 18:11 13 Jul 2007

You see I think that would work and I would be happy to use it but our users wouldnt understand it. we need something quite simple so that you could just click type in password and away you go. The other software that is currently installed is exactly that but it doesnt work.

  IanH123 18:12 13 Jul 2007

oh yeah you said you havent worked in a corp enviroment imagin you parents or grand parents trying to use it thats kinda how it is.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017