Graphics problem....I think.

  dagwoood 03:43 15 Oct 2004
Locked

I've been having problems getting the demo of Far Cry to work click here

When I try to run it, my screen just goes white and my system freezes.

As per my other thread, I've installed different versions of Catalyst drivers, reinstalled my chipset driver(agp to cpu), disabled fastwrite, changed my RAM speed and tested my memory, and it still won't work.

There was an error report generated, which reads:


Stream Engine Initialization
Script System Initialization
Network initialization
Physics initialization
MovieSystem initialization
Renderer initialization
System: INFO: DirectX 9.0c installed
System: VideoCard Detected: ATI (Radeon 9600 Pro)
Direct3D9 driver is creating...
Best-match display mode: 1024x768x32 (Error=8)
ERROR: Chosed NULL Ref Device that can't render anything
Error: Couldn't initialize 3D environment (E_FAIL)
*** Clearing render resources ***
CRITICAL ERROR>
Exception: 0xC0000005, at Address: 0x001B:0x40047B3E
Exception Code: 0xC0000005
Exception Addr: 0x001B:0x40047B3E
Exception Module: Unknown>
Exception Description: Attempt to read from address 0x00000000

The memory could not be "read"
=============================================================================
2) function=0x40047B3E
1) function=0x40047B3E
=============================================================================

After reading the above, I went into dxdiag and ran the tests for Direct3D, the box spins really quickly, it's just a blur.

Can anyone shed any light on this please.

Running on XP SP2, Athlon XP 3200+, 2x512 pc3200 RAM, Radeon 9600 256MB card.

Cheers, dagwoood.

  ICF 07:51 15 Oct 2004

Have a look here click here

  ICF 07:53 15 Oct 2004

Or here click here

  dagwoood 10:17 15 Oct 2004

Thanks for the links. The problem is that they assume you can load the game and I can't even do that, or what they say to do, I've alreadly done.

Cheers, dagwoood.

  The Ghost of Inept Pig 10:49 15 Oct 2004

'lo again dagwoood,

I'd suggest a search on the Ubisoft official forums (Far Cry Bit:click here)

I've found two threads so far that have people who have had the same problem as you, click here and click here

There's many more too, hope you get it working soon..

  dagwoood 14:36 15 Oct 2004

The Ghost of Inept Pig, hiya.

I'll check out your links and do a search of the forums as you suggest.

Thanks for you continued help, it's really appreciated, dagwoood.

  ICF 18:06 15 Oct 2004

Do you have the Net Framework update installed from Microsoft Update?

  dagwoood 20:43 15 Oct 2004

No, I don't have the .NET Framework s/w installed.

I assume you mention this because I have catalyst drivers installed, but I downloaded the control panel and graphics drivers as seperate downloads so as not to install the Catalyst Control Centre(I found it was pants :0) )

Cheers, dagwoood.

  dagwoood 02:24 16 Oct 2004

I think I'm going to knock this one on the head guys. I've been, with your help, trying to get this to run for over 2 days now and I've had enough.

I've followed the different links and couldn't find a definitive answer to my problem. As I've tried numerous things to sort this and it STILL wont work, I'm at the stage where I want to throw my pc out the window!!!

Thank you all for the advice/input/links.

Cheers, dagwoood.

P.S. Just to put my mind at rest, if it was Direct3D/memory issue, am I correct in thinking I wouldn't be able to run something like, say, 3DMark03?

  dagwoood 02:35 16 Oct 2004

Above should have read 3DMark05 and NOT 3DMark03.

Cheers, dagwoood.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?