Google Mail link not working

  Pineman100 14:21 23 Apr 2010
Locked

I use Google Mail for my emailing (I run Windows 7 and Firefox).

Until today, when I clicked on the "Mail" link at the top of Google's search home page, I was taken directly to my mailbox page.

Suddenly this morning, when I click that link, I'm taken to a page that says:

Google Accounts
The page you requested is invalid.

There is a "sign in" link in the corner of this page, and if I log in with my email address and password, I'm taken to my main Google Account page. Here I have to click a further link to my mailbox.

But this is a tedious roundabout route. Has anyone else found that the Google home page "Mail" link no longer functions as it did?

Any ideas please?

  Woolwell 14:27 23 Apr 2010

Works ok for me on Vista and Firefox.

  Pineman100 14:46 23 Apr 2010

Thanks for that info, Woolwell. Do you know of any way that I can edit the "Mail" link on the Google search home page, to correct this error?

As a temporary arrangement, I have set up a desktop shortcut to my Google mailbox, but I'm just puzzled as to why the Google search page link has suddenly changed.

  Woolwell 14:59 23 Apr 2010

I very much doubt if you can edit the link.
Have you tried clearing your browser cache - Tools - Clear Recent History - and with just the cache checked?

  Sea Urchin 15:57 23 Apr 2010

For anyone without a GoogleMail account the mail link takes them to the sign in/registration page. Presumably when you setup an account you have an option to remember your address/password and go straight to your mailbox.

Possibly the only way to "edit" the link might be to delete your account and then reinstate it - probably a step too far in the circumstances. Particularly as it may not work. :@)

  Woolwell 16:35 23 Apr 2010

You have the option to remain signed in. If I sign out and click on the mail link then I am taken to page which requires me to log in and then straight to googlemail inbox. Pineman100 seems to have an extra step. If I'm logged in the click takes me straight to the in box.

  Pineman100 17:32 23 Apr 2010

Yes, that's exactly how I've always logged in. On the rare occasions that I have cleared my cookies, I've been taken to the login page, checked "Remember me" and from then on the "Mail" link just took me straight to my mailbox page.

I'll try Woolwell's Clear Recent History suggestion and report back.

By the way, my wife has discovered that exactly the same thing now happens on her Google Mail account! I installed Windows 7 for her yesterday, and we are networked on a Home Group. Could that be related to this problem, or do you think it's a coincidence?

  Pineman100 17:36 23 Apr 2010

I tried clearing the cache. No change, I'm afraid.

  Woolwell 18:30 23 Apr 2010

Is it a Windows 7 thing as I am on Vista? It works ok for me on IE8 and Firefox. Have you tried with IE8?

  Pineman100 18:48 23 Apr 2010

Yes - exactly the same trouble in IE8.

As regards W7, I've been running it for some months without this problem.

I just don't understand it.

  Woolwell 19:57 23 Apr 2010

Delete google cookies and try again?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?