google has gone Greek

  johnincrete 09:16 08 Feb 2013
Locked

I live in Crete, Greece and, up to now, I have had no problems with Google searches. But now, everything is in Greek - logon, search dialogue boxes and search results only find .gr URL's What can I do to tell Google that I want English and .UK or .com results?

  chub_tor 09:39 08 Feb 2013

At the very bottom of the Google search home page is there a line of text (probably in Greek)? If so the far right one of those should be Google.com - there is on the Google UK page anyway. To get to Google.com you should click on that far line of text as they are links and it might just take you to the Google.com page

  xox101 11:14 08 Feb 2013

Google seems to have a time limit on when it decides you are no longer a visitor but a resident and then changes it's search page to whatever language it thinks is local. I have a mate who spent three years in Kefalonia and after a few months had the same problem.

  lotvic 11:26 08 Feb 2013

Try google.co.uk/webhp?complete=0

When I go to google.gr page is in English and underneath 'Google Search' 'I'm feeling lucky' there is 'Google.gr offered in: Ελληνικ?' and at very bottom right of page a link to go to google.com

All my searches from google.gr return results in English.

I vaguely remember something in the past about setting Language or maybe it was along the lines of not 'automatically find my location' (or both)

Can anyone remember what and where the above settings are?

  Batch 16:01 08 Feb 2013

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?