Google Earth

  Clapton is God 16:14 20 Apr 2013
Locked

Since I updated to the latest version of Google Earth (7.0.3.8542), Street View fails to work.

Whenever I drag the little orange icon to a place on the map it goes to ground level view rather than street view.

Am I dong something wrong or is there a setting I need to alter?

O/S is Win 7.

  Fruit Bat /\0/\ 16:16 20 Apr 2013

Usually if it switches to ground view then there is no street view available for that area.

I gave up on google earth and do it all from google maps now.

  Clapton is God 16:28 20 Apr 2013

I know that street view is available for the area.

It's the area I live in and street view has always been available in previous versions!

  john bunyan 18:48 20 Apr 2013

I am sure you will have updated your graphics drivers, but I had a similar problem a while ago and it seemed to do the trick.

  muddypaws 18:59 20 Apr 2013

Clapton is God

That version Is working OK on XP. The only difference is that there are no grey ovals to move forward on. Just have to click ahead on the road. I haven't changed any settings.

  muddypaws 19:02 20 Apr 2013

Does it state 'street view' top right after you have dropped the man?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?