Glitchy Logitech C-140 Speakers

  [Phlip03 20:37 18 Oct 2008
Locked

The problem is that with these:

click here

new speakers I got, I can't use the Generic or most of the other environment sounds here: click here, because the speakers then sound really grainy/glitchy. Is there any way I can change the environment without getting these glitchy side-effects? The None> makes the music sound so plain.

I can't find the speakers I'm looking for to download the drivers, here:

click here


Appreciate any help you could give. Thanks.

  GaT7 21:57 18 Oct 2008

So I guess it also happens when you use the Realtek equaliser?

Have you tried with another media player? I sometimes find a similar problem to yours when I use Windows Media Player with it's equaliser on/tweaked.

Another reason I can think of is that those speakers aren't powerful enough to handle the 'tweaked' sound, or even extremes of highs & lows. Try to swap with another set if possible to rule them out.

Btw, speakers don't need drivers to function - it's the soundcard that does. Check if you have the latest. If not, download the latest, install them, reboot & see if it makes a difference. G

  GaT7 21:58 18 Oct 2008

Try to swap with another 'more powerful' set if possible to rule them out. G

  [Phlip03 23:02 18 Oct 2008

I tried the same song on iTunes, and it still sounded glitchy, but slightly less.

There must be some options in Windows Media Player for me to change something to help this? Or where would I download a better sound card?

  GaT7 00:51 19 Oct 2008

Disable WMP/iTunes equalisers if they're on, & try again.

If above is no help, visit your motherboard manufacturer's website, download the latest audio drivers from there & install them (if you need help, post the motherboard make & model number when you reply).

The very latest Realtek HD audio drivers can be found at click here, but Realtek themselves recommend getting them from the motherboard manufacturer. G

  Gandalph 02:03 19 Oct 2008

I've got the same speakers as those and I am using the realtek sound system. I have mine set to room and they sound really great. Try the same setting.

  [Phlip03 02:52 19 Oct 2008

Crossbow, I can't find anything on equalisers. XD

Grandalph, At that setting they still sound glitchy. =(

  [Phlip03 16:53 20 Oct 2008

Any help, please?

  Stuartli 19:47 20 Oct 2008

I also have the same speakers.

Using the Realtek Sound Man control panel's equaliser, all the various sound effects can be clearly discerned.

However, I keep it on None (i.e. flat) as I detest unnecessary changes to a sound input (goes back to hi-fi hobby). The speakers themselves have the bass set to flat (it does tend to alter the sound too much).

In Windows, the equaliser can be found via View>Enhancements>Graphic Equaliser.

  Stuartli 19:48 20 Oct 2008

Is the fact that your Karaoke setting is at 40 anything to do with your problem?

  MCE2K5 20:10 20 Oct 2008

it's +0 not 40

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?