Gigabyte X58A-UD3r Motherboard - unable to see external drive connected by eSata

  plusman 15:11 09 May 2012

I have a PC containing a Gigabyte X58A-UD3R rev2 motherboard running Windows 7 Professional X-64. I have recently upgraded one of the internal disk drives to a Crucial 128Gb SSD and as part of the upgrade I reinstalled Windows 7. I also updated the Bios to the current one on the GB site (version FH).

The ports I am using are:

Intel Port 1: SSD Intel Port 2: Data drive (1Tb Maxtor Sata II drive) Intel Port 3: Other data drive (for backup) (2Tb WD Sata II drive) Marvell Port 1: DVD/RW Drive Marvall Port 2: DVD/RW Drive

(I installed the two DVD drives on the Marvell Ports as these were not recommended for the SSD by other posters on this forum, and because the first time I tried to use a drive connected to one of the rear eSata ports it was not seen by the PC, and I moved the DVD drives to the Marvell ports in case having 5 devices on the internal Intel Sata ports was the cause of the problem - which it probably wasn't).

I installed the latest drivers and chipset from the GB site.

I have set the Intel SATA ports to AHCI, but left the other ports, including the GSata ports, as IDE.

I am trying to connect to a external Sata drive which is located in a Sharkoon data caddy and connected by an eSata cable. The caddy is externally powered.

Before I upgraded to the SSD and reinstalled Windows, I was able to see the external drive without problem.

When I first encountered the problem, I searched the web and found that I hadn't installed the JMicron drivers (as I didn't see them on the GB website). So I downloaded the latest drivers (JMB36XWinDrvR1.17.63WHQLeSATA) from the JMicron website and installed them.

I am still unable to see the external drive.

I have tried booting up my PC with both the external drive switched on, or switched off and then switched on after the boot has completed - I was unable to see the external drive.

I have checked the Device Manager and I can see that there are two JMicron JMB36X Controllers listed under Storage Controllers. Both devices are supposed to be working properly.

With the external caddy/drive switched on I scanned for new hardware - none was found.

Also during the boot sequence, and with the external caddy/drive switched on, I can only see the 3 internal drives (1 SSD and 2 HDD) listed.

Can anybody else advise what I might try?

Many thanks in advance for your help.

  Fruit Bat /\0/\ 19:07 09 May 2012

1, is it seen in disk management?

  1. have you tried setting the other ports to AHCI?
  plusman 09:04 10 May 2012

Problem solved!

Believe it or not it turns out to have been a broken eSata cable. It must have become broken somehow when I was putting in the new SSD. A different eSata cable solved the problem and all now appears to be working.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?