Getting rid of IE stopping scripts and ActiveX

  erkmatrix 11:30 05 Sep 2008

Hi is there anyway of getting javascripts accepted in Internet Explorer without it first off blocking it until you click accept. I'm design a website and it has a gallery with popup browser windew to open when someone clicks an image. I've seen this done on other websites using javascript:popupWin and it doesn't come up with "To help protect your security, Internet Explorer has restricted this webpage from running scripts of ActiveX controls"

With my site it comes up each time when launched in IE, its ok though in firefox. Anyone got any ideas of how to not have it come up and have a image clicked popup browser open to show enlarged image. There must be a way as these other sites it doesn't have a warning.

I'm using Dreamweaver CS3 and the behaviors to launch the browser window when clicked.


  Eric10 12:37 05 Sep 2008

Does this happen just when you run the site off your local hard drive or when it is accessed from the Internet?
If it's just off your local drive then go to Tools, Internet Options, Advanced, and scroll down to the Security section. Tick "Allow active content to run in files on My Computer". You can also allow active content to run from CDs by ticking the box above if appropriate.

  erkmatrix 14:20 05 Sep 2008

Yeah its not on the internet yet as still building so just on my local drive. Should it be OK and not appear when my site is live on the net.


  Eric10 16:10 05 Sep 2008

It won't happen when your site is uploaded but it's still a pain when you are developing your site so I have made the modification to mine as I outlined above.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

Camera tips to take better iPhone photos

Comment transformer un iPhone en borne Wi-Fi ?