GeForce FX5200 severe problems

  Dante001 00:06 18 Apr 2007
Locked

Hey guys i really need your help.

Okay, so I just bought an Nvidia GeForce FX 5200 128MB Graphics card for my desktop computer.

I followed the manual very carefully. Opened my computer and slotted the card into my PCI slot. Plugged my monitor/power cables...etc in and turned it on.

Now, the diagnostic screen appears but wont go past that screen. I try to enter my BIOS but it wont let me. All I get is a black screen of eternity. Please can you tell me what I have done wrong?

I tried reversing the situation by taking out the graphics card and now it doesnt work either way! i cant get onto my operating system or BIOS! :(

  phono 00:18 18 Apr 2007

With power off check that all cables, cards, RAM modules and so on are all firmly seated in their various slots and sockets and try again.

You did take adequate anti-static precautions and make sure power was off before making any changes I assume?

  Dante001 13:52 18 Apr 2007

i made sure to do the static tests like the manual explains. I also tried realigning the cables/components so they are properly seated, but im still not getting anything. Is there anything else I can try? Thanks

  phono 23:08 18 Apr 2007

Try stripping the system back to motherboard with CPU, RAM and video card and nothing else attached, will it POST now?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Best of the Grad Shows 2017: University of the West of England (UWE)

Best value Mac: Which is the best £1249 Mac to buy

Les meilleures GoPro 2017