Games dont play since Security suite upgrade

  govanboy 01:04 16 Feb 2007

Hi, I upgraded from System Mechanic 6 Professional to S.M 7 Pro. Had Major problem on installing , sorted by Iolo issuing a newer version on Website for downloading .....Program works great now except it appears to have caused some Games to stop playing. Both Medieval and Rome Total War played well on 6 but don't get passed initial stages after installing 7. They seem to be running o.k , even show " PLAY" button but when you click it the wee eggtimer appears , P.C whirrs away for a few seconds then ziltch !
Tried running with Anti-Virus and Firewall Disabled , same result ....Uninstalled Rome then reinstalled and tried again ,....same short attempt to start then nothing!
I'm running Windows Media Centre / Professional . Can anyone help ? ...I'm in serious trouble with Grandson if he misses his wargames . Kaspersky is excellent program but support is unbelievably slow , hence this request . Thanks Folks

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?