G drive not there now?

  JITC1 19:22 21 Dec 2009
Locked

Hi all,

I have an 80gig external drive connected to my desktop (G drive) powerd by USB. All was well until yesterday when it didn't show in my computer, (Never take it out). I took out the USB cable and put it back in and it was still missing. When I checked the USB conections under remove hardware, it comes up as 811/atapi and I cannot get into it. I cannot do anything to access it. The properties icon for the device says "This device is working properly." and under volume there 0 capacity and is called disk 7.

The disk is only 40-50% used.

I have Vista business
Any help will be appreciated.

Merry Xmas to you all

  Technotiger 19:20 21 Dec 2009

Does it not have its own Power Supply?

  Technotiger 19:21 21 Dec 2009

My Crystal Ball Christmas prezzie came early :-)

  Fruit Bat /\0/\ 19:22 21 Dec 2009

Go into disk management and see if the drive shows there.

click here

  JITC1 19:01 22 Dec 2009

TG, its powered by USB.

FB, I followed the link and the disk says its not initialized. I tried to initialize it and it says its not ready

  Technotiger 19:09 22 Dec 2009

Try a different USB slot - preferably a rear slot on the PC, or a powered USB hub.

  rawprawn 19:10 22 Dec 2009

Right Click And Format it.

  JITC1 20:29 22 Dec 2009

I have tried another USB port but the same thing happens.

rawpawn, I cannot get the option on it as it only shows up in the safely remove hardware. It doe not show when I choose my computer (like it used to).

I tried a system restore but that didn't help.

  birdface 20:53 22 Dec 2009

Showing off a bit.Answering the questions before they are posted.
Maybe try the lottery tomorrow night.

  Technotiger 21:03 22 Dec 2009

2 27 30 34 37 45

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?