Front usb's wont recognise camera

  merc. 11:54 27 Nov 2007

I had trouble installing my Canon camera software on my new computer.

After 2 attempts using the front 2 USB’s both failed to load drivers, which I had on computer.

On the 3rd attempt using one of the rear USB’s drivers finally loaded and camera works ok now

My problem now is the front 2 USB’s wont recognised my camera which means I have to use the back USB’s not very handy. How can I get the front ones to recognise my camera to make life easy.

Thanks Merc

  Totally-braindead 12:03 27 Nov 2007

It might be a stupid question and you've probably checked but are you sure the front USBs are working?
Have you tried something else on them?
Did the camera work before?

One of my friends has a similar sort of problem. I went round to his house last week with my pen drive and the front USB just wouldn't recognise it, in fact it locked up the PC. I plugged it in a rear one and it worked perfectly. He plugged in a USB games controller to the front and it worked perfectly. I'm not sure why this would be and the conclusions I have reached are either the pen drive needs more power than the USB ports on the front can give, which is possible I suppose but I consider unlikely or the front USB are 1.1 not USB 2.0 ports and that might be causing some problems.

In short I don't know whats causing it.

If you can't find another solution then my only suggestion is to buy a card reader and connect that permanantly to one of the rear ports. Something like this click here=

  merc. 12:11 27 Nov 2007

yes my front usb's work the recognise my external hard drive and my other camera (a Panasonic) I have had a look under device manager and one of the usb "mass storage device" has a yellow mark under it which says has not been prepared for removal but I have nothing plug in.

It also Say's to fix the problem unplug the device from your computer and plug in again.

Should also have mentioned running windows XP

  Clapton is God 12:11 27 Nov 2007

I had a similar problem with certain items refusing to work in front USBs but happily working in rear USBs - but, as you say, inconvenient if you have to grovel around at the back of the tower to remove the USB.

I solved the problem by connecting a USB 'extension' with a 1 metre lead to one of the rear USB ports and sitting the 4-port USB socket on the top of the tower so that I can easily get at whenever I need to.

  xania 13:21 27 Nov 2007

In device Manager, delete the USB item with the yellow exclamation mark then reboot your computer.

  merc. 14:01 27 Nov 2007

Thanks for advice did what you said and it cured the problem, haven't tried my Canon camera yet will wait till get more photos may be have to come back if it wont load from front usb's

Thanks all for replies


  kjrider 16:27 27 Nov 2007

I have had similar probs with USB ports and also USB leads. Some work with some USB things, but not with others. May be they are cheap or faulty leads that I had, but it drove me mad finding out it was the USB lead.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?