Front USB Ports not working with USB 2 devices

  Giggle n' Bits 13:48 26 Jan 2007
Locked

winXP SP2, ASRock P4i65G motherboard.
Have wired up the Front usb Ports from the case to motherboard header 67.

A USB Mouse will work fine and detect no problem from the front USB ports but put on a Memory USB 2.0 memory stick and it comes up with maulfucntion error please re-connect your device.

Any suggestions would be great. Can I ask is there are difference in the usb ports on front panel cases do they all support USB 2.0 ? as the case is a Antler PC-146 Model No.

  skidzy 14:59 26 Jan 2007

Hi Dusty,you may have solved an old issue i have with this mobo thankyou.

Check your Bios,that usb 2.0 is enabled.Have you also checked device manager for any yellow exclaimation marks under universal serial bus controllers ?

You could try uninstalling everything under the usb headings and reboot,this will allow xp to reinstall the generic drivers.

  skidzy 15:04 26 Jan 2007

Hi again Dusty,i see we have been cross posting with your other thread,i will not post to that thread any more...just here.

  oldbeefer2 15:21 26 Jan 2007

There does seem to be some difference between front and back on my Evesham. I have an external hard drive for back up which works fine on the back ports, but just sits 'clicking' when connected to the front.

  skidzy 15:28 26 Jan 2007

I do believe i have read before that some mobo's will only have usb 1.1 on front ports,i may be wrong and was a while ago.

  skidzy 15:32 26 Jan 2007

ive just read the manual and the front ports should be enabled to usb 2.0

However as i posted earlier,it may well be a bios change to enable this.Sorry off out now,but will check over the weekend.

Have you unplugged all usb devices and tried the front port ? if still no go,maybe the psu is not up to the job.I did replace mine with a 500watt while rebuilding this system.

  Giggle n' Bits 20:58 26 Jan 2007

I have no Rear USB port occupied at the moment as I have just built the machine and want to get the USB 2.0 on the front working.

I have upgraded the PSU to a 450Watt which is ample for spec of the system.

Using the front USB with say a USB mouse or Digital Camera works fine but stick on a High speed USB 2.0 Crucial 2GB memory stick and its not playing so normal usb works fine just usb 2 on front ports its been daft.

Have also noticed, does this happen with yours if you power on the computer it goes of for a second then re-powers and boots up. Strange. very tempted to change the memory next.

I have Kingston DDR400, arh maybe this is the problem. The default BIOS for the DDR 400 was 333 Auto and if you require to use as 400 (200) then you have to manually change in BIOS.

Going to change in Bios back to Auto default to see what happens.

Tried but no difference.

  Giggle n' Bits 21:01 26 Jan 2007

No Yellow exclamations ans usb Enable in BIOS ok.

Does anyone know if all Case Front USB Ports can support USB 2.0 or is there actually a difference or is it down to the motherboard to which a Front USB Port is connected ?

  woodchip 21:03 26 Jan 2007

Some Motherboard have a mix of USB 2 and USB 1,1 ports or headers

  Giggle n' Bits 21:10 26 Jan 2007

Hope your C.V isn't stuck on snow ! and your well ! good to hear from you been a while.

Yes I understand that some have USB 2 & others v1 usb but this motherboard has USB 2.0 headers x2 only thing is when connecting Front USB ports from case to motherboard header it only works as standard USB 1.0 and will not work with any USB 2.0 devices.

Have ruled out PSU and cable orientation is correct there are no jumpers aparts from the 5v SB one and this complies to the PSU being 2amp or more on the 5v.

I can only think the memory has something to do with it.

Using Kingston KVR400X64C3A/512 only thing is Kingston do not list ASRock in the memory configuratior so if anyone knows if this memory is or is not compatible with my P4i65G motherboard I would be interested.

Also thanks woodchip for you call, good to hear from you happy new year.

  woodchip 21:18 26 Jan 2007

Have you gone through the Motherboard Manual? also it may need a BIOS upgrade. Not something to e taken lightly, May be best to buy a USB extension to the back of the comp. No Snow hear. But have been getting Renault Laguna 1.9 turbo diesel sport ready for MOT on 27th Feb. Front end cost a arm and a Leg for parts. good job I did the work my self. but all sust now

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

What is ransomware and how do I protect my PC from Petya?

Microsoft Surface Studio – the artist's hands-on review

Original iPhone review

Comment mettre à jour Kodi ?