Tracey73 21:50 25 Oct 2012

Since yesterday I have been having a problem with my laptop when I search the internet. Some searches take me to the relevant websites (but they load a lot slower than normal), but now and again pages take much longer to load and then I am redirected to with a message about a DNS error. I've spent all evening reading up about Freecause and trying to get rid of it but to no avail. I run Eset NOD32 antivirus and Spybot, but neither of those pick up on the problem. I've also tried Malwarebytes and Microsoft Safety Scanner, both say no threat found aswell. My laptop runs Windows 7 and I use Internet Explorer 9, mainly Google but also Yahoo search.

If anybody could offer any advice I would very grateful. Thank you!

  woodchip 21:54 25 Oct 2012

You should set your browser to "not allow redirect" in Browser Settings if Firefox go to tools/Options

  woodchip 21:57 25 Oct 2012

May be a good IDEA to clear all your Internet History and Cookies

  Nontek 22:07 25 Oct 2012

Try a System Restore back to before this started.

  lotvic 22:43 25 Oct 2012

Do you have the Nectar Toolbar by any chance?

I found this info about on it seems that you get redirected through the Freecause in order to collect points.

  Tracey73 11:31 26 Oct 2012

Thank you very much for all your replies. I'm beginning to think I didn't have a problem but the fault lay with my internet conection.
I did have the Nectar toolbar but I'd had it for well over a year without any problems, but I tried uninstalling the toolbar last night anyway to see if it made a difference. The Freecause page didn't appear again but still pages were taking forever to download. I tried system restore, clearing cookies etc, altering browser settings - everything recommended but it was still playing up, sometimes pages loading as normal and other times taking forever, odd occasions displaying "cannot connect to the internet". I was convinced it was a virus or spyware until I spoke to my dad this morning who is with the same ISP (BT) - he has been having the same problems and only over the last two days like me. I did check BT's system status and there were problems in our area yesterday and the day before, but they were apparently resolved by late afternoon, so I assumed it wasn't that. This morning everything seems to be back to normal with pages loading straight away, so I can only assume it was BT's end causing the problems.

Thanks again!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Musique en streaming : Spotify vs Deezer