"framedyn.dll" not found...can't do System Restore

  barnetbird 09:56 16 Sep 2006

For some unknown reason, when I attempted to create a restore point the following message came up:-

rstrui.exe - Unable to Locate Component
This application has failed to start because framedyn.dll was not found. Re-installing the application may fix this problem.

Any help would be much appreciated!

  johnnyrocker 09:58 16 Sep 2006

if xp try sfc /scannow and have your disk ready to replace any corrupt/missing files.


  VoG II 10:07 16 Sep 2006

and if that doesn't solve it click here

  Gongoozler 10:08 16 Sep 2006

Does this help click here;en-us;319114

  Gongoozler 10:09 16 Sep 2006

Too late - and my link didn't work as well as VoG™'s

  barnetbird 11:08 16 Sep 2006

I've tried the methods outlined on the link VoG provided; however, nothing worked.

Alas, I purchased my Dimension through Dell and wasn't provided with a disk for XP Home Edition. I was hoping I could resolve the issue without reverting to Dell, despite having an extended warranty.

Thanks for your help.

  VoG II 11:15 16 Sep 2006

You can try downloading it from click here

It needs to go in the c:\windows\system32\wbem folder.

  barnetbird 11:43 16 Sep 2006

With a little bit more tinkering, I've solved the problem. Although I couldn't find the framedyn.dll the first time I searched for it, I rebooted and tried again, locating it successfully! After copying it to system32, I'm happy to say everything is back to normal.

I can't imagine what happened to cause the problem in the first place as I've hardly used my PC in the last couple of days and only visited the same sites I normally do (no problem prior to then). But problem solved, end of!

Thanks again for your help; much appreciated!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

ManvsMachine win UK's only Gold Design Cannes Lions award

iPad Pro 10.5in (2017) review

Comment connecter un MacBook à une TV ?