Formatted HDD shows as unformatted

  Bargee 17:46 18 Oct 2008


I've just upgraded my PC including MB, RAM, CPU & HDD as well as OS (W2k to XP Home SP3).

Before I started, I copied my primary single partitioned HDD program & data files to the slave HDD (both Maxtor), this disk being partitioned into 2 logical partitions.

Having hooked this drive into the upgraded system, I now find that only one partition is seen & that partition comes up as unformatted when I click on it in My Computer. Obviously I haven't proceeded with the format.

I've even tried attaching the drive via USB in an appropriate drive case only this time it isn't even recognised, although the similar drive I took out of the case was. I've even tried the drive that was copied from, no joy either.

Is it possible that I've somehow deleted/corrupted some key files that XP needs to be able to read the drive? If so, how can I get around this?

If not, then what can I do do retrieve the files?


  Technotiger 17:56 18 Oct 2008

Only guessing really, but have you checked that Master/Slave jumper pins are set correctly?

What format is the unreadable drive FAT or NTFS?

  Bargee 11:04 19 Oct 2008

Thanks Technotiger, I should have said that with the Maxtor ATA drives the setting for slave is no jumper attached & this is how the drive is set. Both drives are formatted NTFS.

When I tried the original drive that was copied from, that too was set to slave & wasn't seen.

  Technotiger 12:21 19 Oct 2008

Your main drive should be set as Master, with the second drive as Slave. NTFS is correct.

  Bargee 12:39 19 Oct 2008

Yes, I know & that is exactly how it was set up.

XP was loaded onto the SATA drive which was made first boot disk in BIOS, the DVD ROM Drive was set as master with the ATA HDD set as slave on the EIDE slot (there is only the 1 EIDE connection on this particular MB). It should all have worked.

Now, I do have another ATA HDD loaded into a drive case that has both NTFS & FAT32 partitions & this disk IS readable. That is what makes me think that somehowe, the disks I'm having problems with, have become corrupted in some way.

All I did for the upgrade was remove the old components & replace them along with those I was keeping, nothing else. I don't understand it.

  Technotiger 12:43 19 Oct 2008

It is possible of course that corruption is the problem, have you tried running click here which might sort it out?

  BurrWalnut 14:18 19 Oct 2008

You haven’t by any chance used GoBack to do the original copy?

Windows doesn't recognise drives that have GoBack enabled because of the changes that GoBack makes to the MBR. Boot from the drive, press the Space Bar to access the GoBack menu and disable it. The drive should now be recognised by XP.

  Bargee 19:05 19 Oct 2008

Technotiger, I'm going to try your link as soon as.

BurrWalnut, you may have a point with this one, the slave drive did have GoBack program files saved on it, although not an installation, & it could explain why XP won't recognise the original master HDD that the files were copied from as this had GoBack installed to run on startup. I should say, that this disk was the master HDD in the pre upgrade system which ran W2K. I am planning to use it & the other componets replaced in the upgrade, to upgrade another older PC running W98SE thats become problematic. I wanted the original slave HDD in the upgrade as it contains a lot of data, photo's etc.

I think I may have to undo the upgrade, replacing the original components to fix this problem, making sure that only data files are on the disk I want to keep in the upgrade PC. Engaging 20/20 hindsight, I Should have done that in the first place I suppose.

Ho hum.

  woodchip 19:23 19 Oct 2008

All Drives Should Have a Active Primary Partition, Not just Logical I would say thats your Problem, followed by logical

  woodchip 19:32 19 Oct 2008

PS you cannot just copy a Operating System and or programs etc You have to Clone or Image the Old Drive to the New

  Bargee 08:16 20 Oct 2008

Your first point is very valid & I'll make sure that will be the case.

Your second point is also valid except I didn't want to copy the OS in the first place. Mind you I did try to clone the master HDD, but was unable to, perhaps this set in motion the chain of events leading to this problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires