formating a usb flash drive ?

  acein1 20:11 21 Jul 2007
Locked

hi i tried to format a "usb" flash drive by, right clicking and choosing "format" it tells me i cant format this drive because its in use ??? etc ,im sure ive done this several tims before without a problem any ideas please

  Andy1991 20:12 21 Jul 2007

restart then try it, if that does not work then i would try booting into safe mode now that ur C drive is working. In safe mode try formatting there. U could also try a program called unlocker to see whats is accessing a file, but i think it unlockes directories as well. I will look for it.

  octal 20:15 21 Jul 2007

Have you tried formatting it via My Computer?

  Andy1991 20:22 21 Jul 2007

U could try looking in device manager for prolems with the device and disk manager (u remember to get into that) and see if the format option there works. ;-)

  Andy1991 20:50 21 Jul 2007
  acein1 21:18 21 Jul 2007

ok thanks to all for your help
ive tried safemode, unlocker (thanks andy),and also tried via "disk management" still no joy,i keep getting the same message about "drive in use"

  Andy1991 21:25 21 Jul 2007

did u try the Device manager

START > Right click "My Computer" > Properties > Hardware tab > Device manager > look for ur flash drive in there and see if there are any yellow or Red symbols on its icon.

PS thanks for the E-Mail, don't know how u did that.

  PalaeoBill 21:30 21 Jul 2007

Try opening a command window and running chkdsk /X

Start>Run> command

(If your flash drive is E: for instance)
In the window run:
chkdsk E: /X

This will force a volume dismount and removed any handles. You should then be able to return to explore or my computer, right click and choose format.

  woodchip 21:34 21 Jul 2007

Check System Restore is not trying to Safegard the drive, Turn System Restore of for the Drive Letter if you see it

  acein1 18:36 22 Jul 2007

many thanks to all who tried to help,in spite of trying everything suggested, still no joy,yet ,when i took it round my friends house this afternoon just stuck it in his p/c ,right click and bingo,i brought it home and tried it in my p/c and all is well back to normal ?????
so there you go ,thanks again

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?