Floppy Drive Problem

  Anti_Virus 18:52 06 Feb 2006
Locked

Hi, I'm having a problem with my floppy drive. I can't find it in My Computer (XP) or in disk management or in hardware. So i took it out to put in another spare one i have from an old pc. When I took the drive out, i heard a rattling, and found a mini-cd (you know the ones that fit in the inner circled of a cd drive) that had been stuffed into the floppy drive by my cousins. Nevermind. But I thought that I'd solved the problem and it was just the cd that had been in there that was causing the problems. So I put it back in (the original not the spare). It still didn't work. So i took it out anp put in the spare. Still didn't work. I've run out of ideas. Surely the problem was caused by the cd jammed in to a floppy, so why won't the spare work. Btw, also tried pushing the connectors just in case they were lose, still no go. Anyone help?

  Diemmess 19:02 06 Feb 2006

Don't expect me to say why, but I have been caught by A: going walkabout.
Only discovered after fitting a brand new drive.

Look in the BIOS and you may find that the Floppy drive has been disabled!

  keith-236785 19:10 06 Feb 2006

also possible but highly unlikely due to the disc being plastic, that it could have caused a short out to the motherboard. do as Diemmess says, then check in Device Manager for the floppy drive, it might be disabled there, or not even present.

stupid question i know but have you remembered to connect the power supply to the drive? the simplest of things can catch us out sometimes.

good luck

ps, when you are in the bios, see if there is a setting for "swap floppy drives" this would change the floppy to be drive B: dont know if it would make any difference but you got to try anything.

  Totally-braindead 20:06 06 Feb 2006

Also use the cable from the other PC and see if that helps.

  Anti_Virus 18:57 07 Feb 2006

Cheers for all your replies, I did as Diemmess said and result, it WAS disabled so i changed it to 1.44MB 3 1/2, and it came up in My Computer. I was in the process of writing a thank you to Diemess yeaterday (at the time he was the only one to reply), but then I thought i better check if it worked. Bad news. everytime i put a disk in and try to access it, it says there is no disk in drive A:/ so now i need your help again....

  Diemmess 16:16 08 Feb 2006

That's sad!
Can only suggest basic things-
The floppies are already formatted or contain a file or two?
Have you tried a different cable?
Unlikely to error this way, but you do have the cable the right way round?
If it is the floppy disk controller on the motherboard I have no idea how to check/repair it if fault there be!

  Diemmess 16:19 08 Feb 2006

How about any yellow triangles in device manager > Floppy Disk contollers or Floppy disk drives?

  keith-236785 20:55 10 Feb 2006

if you have the windows cd, you could right click the floppy disk controller in device manager and uninstall/remove it. restart windows and it should automatically re-install the floppy controller (thats the bit you will need your windows cd for)

before doing this, make sure you have the motherboard driver cd at hand, it might be needed to re-install the floppy controller (cant remember which it is)

apart from Diemmess's suggestion about the cable being the right way round then im a little stuck here.

best of luck

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?