Floppy drive issues

  Verdani 23:24 19 Sep 2006

I'm using an MSI P965 Neo, attempting to install Windows XP Pro on a SATA HDD. Of course, I need to install the drivers for the drive from a floppy during installation. The problem is, I can't get the floppy drive to detect in the BIOS. No matter what I do, which cable I use, which boot order I have things in, I cannnot get the BIOS to see the floppy drive at all - neither can Windows when it asks for the drivers.

I know this issue is uncommon. I've never heard of it before. The drive works - I used it on my old mahine - but it's definitely not working here.

Any suggestions?

Thanks in advance!

  DieSse 00:18 20 Sep 2006

First you need to make sure the cable is fitted correctly.

It only goes one way round. One ond on the motherboard, the other end, nearest the split/twist in the cable, to the floppy. If there is a middle connector on the cable, don't use it, as it will not work.

Then ensure pin1 on the cable goes to pin1 on each connector - you may have to actually look at the floppy to check that end though the motherboard usually only allows you to put the connector in one way round. Pin1 on the cable is at the end where the red stripe is along the edge of the cable.

Then you need to check the BIOS to ensure the correct type of floppy is selected for driveA - this should be 3.5" 1.44MB. If it's wrong it won't work.

Then check that if the BIOS has a "swap floppy drives" or similar setting, it must be disabled.

Double check the power connector to the floppy is fitted correctly - it's very easy to push them on wrongly.

Then if all else fails, try a different floppy drive (Isee you already tried different cables).

If it doesn't work after this - and you've done everything correctly, then the only thing left that may be faulty is the motherboard.

If you want, you can also try resetting the whole BIOS to "Fail-safe defaults".

Note - the floppy drive does not auto detect in the BIOS - you actually set the BIOS to the correct type of floppy, then it should work.

You're not by any strange chance using an old 120MB floptical that runs on a hard disk cable are you?

  woodchip 00:24 20 Sep 2006

Have you checked other pages for Floppy drive settings? enable them all

  Verdani 00:44 20 Sep 2006

There's actually nothing in the BIOS that I've found regarding floppy drives. I've done as you said, DieSse, before. There is no place in the BIOS to change anything regarding the floppy. I'll give it another scan just to make sure, but I highly doubt it. I've also tried another drive with the same outcome. It's a normal 1.44MB drive. I can get the light to go on an stay on while the machine's on with the cable in a certain way, so it's no the power cable.

Everything is pointing me at the motherboard. I don't like this at all, it'll be an absolutely huge pain in the arse to get that exchanged.

Quick somewhat unrelated question - I'm attempting to slipstream the sata drivers onto an installation CD to avoid the floppy issue, but right now I have a corrupt install on my hard drive that won't allow me to enter setup to format without an error - is there any other way to get it formated?

  DieSse 00:51 20 Sep 2006

You can't format a hard drive from inside windows anyway - it just won't let you.

You can format the hard drive from the WindowsXP CD - just boot with it, it'll be in the install options.

  Verdani 01:06 20 Sep 2006

That's my problem, when I put in the CD it stops right at the end with an error - 0x0000007B I believe, something to do with the half-installation on the hard drive already.

  Gongoozler 10:57 20 Sep 2006

"There's actually nothing in the BIOS that I've found regarding floppy drives".
A few months back I fitted a floppy drive in a Packard Bell pc for a friend and had just this problem. After some time, and with help from this forum, I discovered that in BIOS, under the "Advanced" sub menu there was an option to enable the floppy drive, and then the drive appeared in the main menu.

  gudgulf 11:27 20 Sep 2006

Try clearing/resetting the CMOS with the motherboard jumper (or by removing the motherboard battery for a few minutes).

It may be that the CMOS hs become corrupted....if so changing the BIOS settings wont help.

  Fruit Bat /\0/\ 13:32 20 Sep 2006

In BIOS also look for FDC (floppy disk controller) make sure it is enabled.

  woodchip 15:44 20 Sep 2006

On my Laptop I use a External USB floppy

  Verdani 01:42 21 Sep 2006

Wow. Resetting the CMOS with the jumper worked instantly. Thanks a lot, all of you - on to my next problem now. I'll start a new topic.. I think that's the best thing to do, hmm?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?