Flight Sim X won't uninstall

  jonmac 23:04 28 Nov 2007
Locked

Following advice to uninstall then reinstall MS Flight Sim X before installing SP1 for the sim I found it wouldn't uninstall without errors.
First Error - 1603 Fatal Error during installation. Then when I continued, another message...Internal Error 2329. 32 C:\Config.Msi\6c249.rtf
I tried a repair of the installation and also a reinstall on top of what's there to no avail.
Help, anyone?

  Technotiger 23:14 28 Nov 2007

You could try a System Restore back to before you first tried to un-install - and/or you could run Ccleaner click here then do a re-boot and then try again.

  jonmac 13:00 29 Nov 2007

Correction, that file extension is .rbf not .rtf.
Tried a restore which failed to complete overnight for some reason so had to kill the system, re-boot then re-do it with another date. Then downloaded CCleaner, ran it and tried again. Still no luck, another error message about not having access to a particular file altho' I'm System Administrator on my home PC.

  crosstrainer 13:03 29 Nov 2007

In safe mode (tap F8 key on boot-up, choose safe mode)

  jonmac 22:24 29 Nov 2007

Not sure how to do this as on my Mesh PC as F8 leads into a dialogue intended to define which sources to boot from e.g. hard disk, DVD drive etc.
The other option the Delete key leads into a recovery procedure in which an XP Pro icon appears (I have XP Home) then a message saying that an XP installation couldn't be found. Strange.

  jonmac 23:02 29 Nov 2007

More accurately (because I just tried it again) the delete key is called "set up" and leads to a screen with 3 choices.
1 - Run the Windows XP native recovery tool
2 - Recover damaged OS or application files
3 - Restore to factory state
I presume 1 and 2 would be relatively safe to run but I would be concerned about 3. Would I lose installed software for instance?

  gudgulf 23:05 29 Nov 2007

Try the F5 key instead of F8 to get to Safe Mode.

  jonmac 08:29 30 Nov 2007

gudgulf
Tried that but it just stopped dead so I had to reboot.

  Mike D 16:21 30 Nov 2007

On my PC F8 also brings up boot options, but if I carry on pressing F8 after I move on from the Boot Options screen I get into Safe Mode OK.

  jonmac 00:16 01 Dec 2007

Mike D - Thanks for that. It worked on second attempt but when I tried the uninstall procedure via Control Panel it just did nothing except briefly flash the Installshield box, then nothing. I have also run CCleaner again, Spybot and Adaware.

  ashdav 01:45 01 Dec 2007

First step is to use Control Panel/Add or remove programs.
If this is unsuccessful then go to Start/My Computer/Programs and delete the Flight Sim folder.
Then use Ccleaner/Registry/Scan for issues/Fix issues then repeat the Ccleaner scan for issues until it returns no results.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?