flash drive from pc advisor

  contractor 17:51 11 Aug 2008
Locked

Drive refuses to accept any files and won't create "new folder" with the comment cannot find the file specified. This is a flash drive given to me when I took out a 3 month trial subsciption.
Aprt from binning it any suggestions on how to cure it.

  Forum Editor 17:54 11 Aug 2008

formatted the drive?

  Forum Editor 18:26 11 Aug 2008

saying that you tried to format the drive, but nothing happened.

Just one more question - when you right-click on the drive and select 'properties' what do you see?

Please reply here in your thread, rather than emailing me.

  contractor 22:40 12 Aug 2008

I see File Type removable disc, File system FAT,used space 4.34 mb, free space 1.93gb,capacity 1.93gb.
When I have tried to copy files into it it also comes up with cannot find the specified file

  woodchip 22:46 12 Aug 2008

Can you see files on the Drive, if you can double click one to see if it opens

  wolfie3000 23:05 12 Aug 2008

Have you tried it in a different usb port?

I find this sometimes solves problems like this.

  contractor 00:17 18 Aug 2008

Yes I have tried different USB ports and another computer same thing happens-I think it must be a duff drive and I'll have to see how to get a replacement from P C Advisor

  GaT7 00:58 18 Aug 2008

Try formatting it in Disk Management:
Start > Run > type diskmgmt.msc > OK

Also check it for errors if it'll let you:
Right-click the drive > Properties > Tools > Check Now > Put tick in both boxes > Start

Finally, if not already set, go to the following location:
Right-click the drive in Disk Management/My Computer > Properties > Hardware > Highlight drive in list > Properties > Policies > Select 'Optimize for quick removal'. G

  contractor 23:27 18 Aug 2008

Formatted using disc management, then went back in to do quick removal bit and it now doesn't show in the window, just the c drice appears.

  MAT ALAN 23:31 18 Aug 2008

I received one of those, binned it after trying to get it to work, more trouble than what its worth to send it back.

Tried it in 3 different PCs none of them manged to format it properly or save files to it...

  woodchip 23:41 18 Aug 2008

You have probably killed it if you formated it with XP or Vista as most likely is Fat12 or 16. Try a Windows 98 boot disc to format the drive if you can still get the letter of the drive click here Tenth File From Top download the File the Double Click the File with a Floppy in the Drive. then start with Floppy and USB stick in Drive You then need to know the correct drive letter to type at the A:\> prompt for it to Format it

(EXAMPLE)

A:\>Format k:


Your Drive letter needs to correspond with the k: above insert the drive letter where the K is then press enter

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Ryzen news - release date, UK price, features and specifications

The pulp art of 80s computer game magazine covers

Best value Mac: Which is the best £1249 Mac to buy

Comment faire des captures d’écran sous Windows 10 ?