Flash drive not recognised

  bramble1 20:58 23 Apr 2006

While I have several flash drives that work OK on another PC, my desktop (XPsp2) fails to recognise them. It accepts that a 'USB mass storage' device has been plugged in and attempts to find the software. After a few minutes the intallation Wizard return with the message 'The data is invalid'.

Any suggestions gratefully received.

  skidzy 21:15 23 Apr 2006

Have you checked device manager for any yellow exclaimation marks ? if any appear uninstall the drivers and reboot...let xp find and reinstall the drivers.

  bramble1 10:11 24 Apr 2006

Thanks for the prompt reply. The device manager within the control panel (after upgrading XP to SP2) now doesn't show any devices - it only list 'default' - whatever this means. The USB ports work fine with other devices such as DSL modems or USB headsets, it's only flash drives that it doesn't like.
When one is plugged in the system recognises the new hardware, starts the Wizard, but then fails with the 'data is invalid' comment. So, it seems to be looking for the appropriate drivers but failing to find them.

  Grantrh 12:16 24 Apr 2006

I get this sometimes too when I use a USB 1.1 port and insert a USB 2.0 flash drive.
And I know they are 'supposed' to be backwards compatible.
The problem goes away when I insert the flash drive into a USB 2.0 port. Maybe it is the same with your PC?

  bramble1 12:42 24 Apr 2006

Thanks for the thought. I've tried both 1.1 and 2.0 USB flash drives - all exhibit the same error. Before updating to SP2 these devices worked OK most of the time, but were becoming increasingly unreliable - that is the system was failing sometimes to recognise them. Now, however, after the SP2 upgrade nothing works...

  Newuser4165 13:09 24 Apr 2006

Does your motherboard have a Via Chipset?
If so updating the chipset driver from Via may help - it worked for me after installing SP2

  bramble1 14:46 24 Apr 2006

Not sure if I have a Via chipset - but your point about updating the motherboard (an Intel SR440bx) could certainly be valid. It's probably 5+ years old and I've never updated the firmware.
I've just checked the Intel site and they no longer offer support - is there another site that you know of that can check the state of the motherboard firmware and offer an update?


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?