Flash Drive Fault?

  Stowit 14:36 04 Apr 2007
Locked

When I plug my flash drive into any USB port on either of my Pcs, Windows (XP) Beeps acknowledging its arrival & an extra drive appears in my computer. However if I try & use the dive I get the message 'please insert a disk in drive X' It has at one time recognized it a a usb mass storage device, but where ever / however I try & look in it I get the same message. Prior to yesterday it worked OK. Has it failed, or is there something I can do? A different drive also works fine.

  recap 15:45 04 Apr 2007

click here it may help?

  Stowit 17:16 04 Apr 2007

Ta, but I'd already seen it & tried their suggestion to no avail. )-:

  postie24 18:07 04 Apr 2007

Try reformatting it

Postie24

  Stowit 18:23 04 Apr 2007

I found the format option, but it wont format as it is 'write protected' If I try 'error checking or defraging nothing seems to happen at all.

  recap 11:15 05 Apr 2007

There is normally a very small switch on the side of the drive to turn on and off the write protection.

  Stowit 11:54 05 Apr 2007

I've had drives as you describe, but this isn't one. Previously I've written data to it, it has just stooped working. I suppose a more accurate title for the thread is 'can my flash drive be repaired, & how?

  Stowit 09:30 07 Apr 2007

It's for the bin then ?

  postie24 13:43 07 Apr 2007

Have you tried what recap suggested,look for the write protection tab on it?
Then reformat it,i cant suggest anything else

Postie24

  Stowit 21:33 07 Apr 2007

As I said, a previous 'drive' had this facility. Not so with this. Only when I've tried to format have I had this message. Normaly it was just plug & play, write / delete stuff at will. It's not so old & only 1gb - cost £9 at a computer fair. I'll just have to bear the loss & not buy an Avixc again!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?