Fixing Run Time Errors

  Grundy02 16:18 11 Sep 2008
Locked

I have a Mesh matrix Pc, using XP as the operating system and Aol as my ISP. For the last few months, I have been plagued with a flow of Run Time Errors, currently of nearly 20 different messages.

I have tried various methods of stopping these messages, including the use of RegCure etc, but without success.

They only seem to occur when I am using the Aol software - which is nearly all the time. I have contacted Technical Support at Aol, asking about patches, but they deny there is any problem with their software and say I should get a local engineer to fix the problem.

But I don't know of a competent engineer and it seems to me that maybe someone in the Forum might be able to tell how to get rid of these Errors.

Please, can anybody advise what it is I need to do to fix the problem?

  brundle 16:36 11 Sep 2008

If you can manage without AOL's software do so, that might solve the problem in one go.

Can you be more specific regarding the errors - when do they occur, on specific pages, at random, what is the precise wording?

Run a system file check; click here

Full scans with antivirus and antispyware are worth doing too.

  Fruit Bat /\0/\ 16:37 11 Sep 2008

Repair XP by replacing corrupt files
Type

sfc /scannow

in the run box, press enter and let system file checker find and replace missing / corrupt file in windows and explorer.This will take awhile to complete and you may be asked for the CD to be in the drive if windows is not preinstalled on the hard drive.

sfc /scannow problems
click here

  Grundy02 17:16 11 Sep 2008

Thanks for your response. Unfortunately, I am contracted to Aol for another 18 months.

The Errors seem to occur randomly and I have not been able to find any common link - they pop up when I am using both the Email services or searching the Internet.

Some examples of the Error messages:-

They all begin with "A Runtime Error has occurred.
Do you wish to Debug?" and after the detail of the error, I can choose between 'Yes' or 'No'

The most common is:-
Line: 27 Error: Object expected. The same message has occurred on Lines: 27, 48,1523 & 3090

Others are:-
Line: 10 Error: 'UmTree' is null or not an object
Line: 68 Error: Unterminated string constant.
Line: 99 Error: Invalid character.
Line: 59 Error: 'textandurls' is undefined.
Lines: 795 & 994: Error: 'document.getElementById(...)' is null or not an object.

Just-In-Time Debugging
An exception 'Runtime Error has occurred in Script. However, no debuggers are registered that can debug this exception. Unable to JIT debug.

I run a full Anti-Virus Scan with Norton Internet Security once a week, but it doesn't make any difference.

I hope this info. may help you to provide a solution to my problem.

I will now run the sfc/scannow and see what results that produces.

  brundle 17:21 11 Sep 2008

Are you up to date with Microsoft updates?

Disable IE script debugging;

Open Internet Explorer and click on Tools, select Internet Options and click the Advanced tab.Tick the box next to "Disable script debugging" and untick the box next to "Display a notification about every script error" (if it's ticked).

  Grundy02 17:38 11 Sep 2008

Thanks again for your advice.

My PC is set to automatically download Microsoft Updates.

I will now alter the settings, as you suggested. But it may now be awhile before I finally know whether, whther this has solved the problem.

  Grundy02 17:41 11 Sep 2008

Thanks for your suggestion. As you will see from the messages with Brundle, I am following the same path.

  Grundy02 14:42 12 Sep 2008

I have tried to run the sfc /scannow programme and shortly after the start I had the screen message:
'Files that are required for Windows to run properly must be copied to the DLL Cache.'

'Insert your Windows XP Home CD-ROM now.'

The Windows XP software was pre-installed by Mesh before they delivered the PC. The only CDs that came with it, are:-
1.) Mesh Computers Recovery CD-ROM and
2.) A8NE-FM Series Motherboard.

So I don't have a separate Windows XP CD-ROM to insert. Does this mean I am unable to complete the sfc /scannow programme?

  Fruit Bat /\0/\ 15:45 12 Sep 2008

click here

follow the instructions to point SFC at the i386 folder on the hard drive.

  Grundy02 16:38 12 Sep 2008

Many thanks for the instructions. I have tried to follow them, but ran into difficulties with the sfc /scannow programme.

Having unchecked the 'Hide....., I then ran sfc again and screen messages came up asking me if I wanted to skip this file. I clicked on Yes, but the original 'Files are required etc.' kept coming back on the screen, until the scan was not able to progress.

Am I making a mistake somewhere in trying to follow your instructions i.e. what is the procedure I should follow after I've unchecked the 'Hide... setting?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?