Firefox not allowing cookies and/or Java

  stlucia 20:55 03 Jan 2006
Locked

When I'm using Firefox, a couple of sites -- Excite is one of them -- report that I can't sign in because my browser is not allowing cookies and/or javascript.

My ISP is AOL (BB), and I am able to sign into those sites direct from the AOL screen, so that surely rules out Win XP, AOL, ZA or any other of my anti-nasties software as the culprit (my Windows firewall is inactive, by the way)?

I've checked the "Allow sites to set cookies", "Allow Java" and "Allow Javascript" boxes in Firefox. What else could be blocking things, please?

  Stuartli 22:14 03 Jan 2006

Have you also checked Load Images from the Content tab?

  octal 22:23 03 Jan 2006

This site will check your Javascript click here

And this one will check Java click here

  stlucia 08:36 04 Jan 2006

Thanks, Stuartli and octal. I haven't checked Load Images -- I'll see what setting it's on when I get back tonight. I'll also test those two links.

  stlucia 19:41 04 Jan 2006

Stuartli, "Load images" is checked, and "for the originating site only" is unchecked.

octal, both test confirm that my browser (Firefox) supports JavaScript 1.3.

  stlucia 15:52 05 Jan 2006

... still the same message, so any other ideas please?

  kevinjuan 16:18 05 Jan 2006

Hi,
I had a similar problem after upgrading to the latest Firefox. My problems were soley with Java though. one of the messages I got was

Error:applet grid notinited.

I had to repair my windows XP to get it all to work properly. Hope this helps.

Regards

Kevin

  stlucia 08:16 08 Jan 2006

Thanks Kevin. Yours sounds like it was a corrupted Windows installation, or something. But the error message I'm getting seems to be simply something to do with the way I've set up Firefox.

Before I reinstall Firefox, any more ideas about cookies and JavaScript options please, 'cause I've checked all I can find (as listed above) and the same sites are still being blocked with the same message?

  octal 08:32 08 Jan 2006

Sorry, I've just notice my second link was incorrect I meant to post this one click here which will test JavaSun as well.

  stlucia 11:56 08 Jan 2006

Thanks, Octal. That link updated my Java for me, but didn't cure the problem.

But I've just found what it was -- although I'd checked the Firefox > Tools > Options > Privacy > Cookies > Allow sites to set cookies box, Excite was listed as a "block" in the list of exceptions, along with several others. Don't know how that list became populated because I've never manually blocked anything, but at least I'm sorted now.

Thanks everyone.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?