Firefox as default browser

  Howard-219717 19:09 21 Mar 2009
Locked

Although I have tried to set Firefox as my default browser, when I click on a (blue) URL in an e-mail or web page, MS Internet Explorer muscles in - very slowly. It's as though IE insists it is my default browser!

How can I keep IE shut in its box?

I'm sure this has been dealt with before, but I can't find the message...

  Stuartli 19:31 21 Mar 2009

Apart from nominating Firefox as the Default in the browser itself, have you also configured Set Program Access and Defaults from the Start button?

  iscanut 19:39 21 Mar 2009

With Firefox open, go to Tools, Options, Advanced then look down to System Defaults and ensure the box is ticked to check that Firefox is the default browser. IE will stay in its box until called for by you. Also do what Stuartli suggests.

  Howard-219717 06:42 22 Mar 2009

Thanks for the suggestions, very clearly described. I followed both, and then re-booted. But no change! IE still launches itself (rather than Firefox) when I click on a blue URL. Should I just 'mutilate' or 'kill' IE in some way?

  howard64 06:47 22 Mar 2009

have you right clicked on internet explorer [on the desktop] then properties then programs. Set values.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

How to update iOS on iPhone or iPad

Les meilleures applications pour enfants 2017