firefox 6 problems - slow spacebar

  Markito 17:04 19 Aug 2011

I have Windows XP Pro and have just upgraded to Firefox 6 (from issue 5) having been prompted to do so. I am not at all impressed. The biggest problem seems to be the very slow working speed of the space bar on sites like Hotmail and also this site. In addition I appear unable to use my sign-in / password at all on some sites. Does anyone have a solution to this? If necessary I am prepared to "downgrade" back to version 5 if possible since its speed is similar - if not quicker - and I had no problems with it. Is it possible to do this fairly easily? Thank you.

  Ex plorer 17:03 21 Aug 2011

Hi I run vista but had trouble running latest Mozilla FF. I went back to version 3.6.20 and its faster than the newer version for me any way.

Go back to the version that suits your PC the best.

Go to control panel and Add Remove remove the latest FF and then go to the Mozilla FF site and down load your favourite version for XP.

  Ex plorer 17:06 21 Aug 2011

This reads better.

Go to control panel and Add Remove. Remove the latest FF and then go to the Mozilla FF site and down load your favourite version for XP.

  Ex plorer 17:14 21 Aug 2011

Of course you will need a back up browse like IE or Opera etc.

  Markito 14:42 22 Aug 2011

Thanks, Explorer. I went back to Firefox 5 and even tried a version of Firefox 3. Strangely enough, the space bar still runs slowly in Hotmail whichever version of Firefox I now use.

There must be a reason for this, but I can't figure it out.

  birdface 15:05 22 Aug 2011

Have you had a look at your add-ons to make sure they are all working.

I have a couple marked incompatible.

That is under Extentions.

make sure your Ad-Blocker is working.

  Markito 14:11 24 Aug 2011

In Firefox I checked the adds on, as you suggested. The following are incompatible: 1. various Java Consoles 6. (disabled) 2. Microsoft NET Framework Assistant 1.21 (disabled) 3. Beef Taco cookie opt out Targeted Advertising. 1.3.6 (I have a choice of "options" "disable" or "remove."

Could any of these really have an effect on the space-bar working slowly in Hotmail and other sites? If number 3, which option do I click?

I repeat that I have no such problem using I.E. as my browser.

Many thanks.

  Markito 11:20 27 Aug 2011

Problem seems to be solved.

I am using an HP laptop and when I disabled the Credential Manager (for fingerprint secure access), the space bar key worked perfectly.

I can't logically see a reason for this, but it works.

Thanks Ex plorer and Buteman for your help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?